Plugin toolbars won't stay in place

bug

#1

Hi,

De toolbars from downloaded plugins won’t stay in place and just float after opening SketchUp again.
The ‘standard’ toolbars included in SketchUp do stay in place.

I searched for a solution online but I couldn’t find one that worked.

I’ve tried to install SketchUp again with ‘run as administrator’ and choose repair.

Installed SketchUp again with ‘run as administrator’ and choose remove and then again for install, no luck

Deleted all folders and files I could find related to SketchUp, deleted all SketchUp folders inside windows regedit and repeated a fresh Install, also no luck.

Since the computer was new and only a few programmes where installed I even restored Windows completely with a clean install. Installed SketchUp with 'run as administrator and the toolbars still won’t stay in place.

Now I’m getting worried :slight_smile:

Additional info and strange behaviour, maybe related…

When trying to download extension from the extension warehouse from inside SketchUp the red button say’s uninstall instead of install? The plugin installed on my other pc, not this one. Also I deleted it from ‘my plugins list’ and still it shows as installed?

Installed SketchUp pro 17, no toolbar problems.

Hopefully there is way to fix this.

Thanks in advance,

Cristian de Kok


#2

Additional information,

‘Official’ plugins like sandbox don’t float after restart, they are turned of again :frowning:


#3

So you experience the before-mentioned problem in a version other than SketchUp Pro 2017, but in which?
Is it older than SketchUp 2013, or is it SketchUp Make 2017? Did you install both SketchUps as administrator?

Do you have by any chance VRay installed?


#4

Hi Aerilius,

The problem is with SketchUp 18 pro on windows 10, SketchUp 17 on the same computer and account hasn’t got this problem.

I don’t have Vray installed.

Also tried it without any virus protection, firewall, deleted internet explorer history and cache but no luck.


#5

Did you install it with administrator priviledges? If it not only forgets toolbar positions but also activated plugins, it probably fails to save the preferences.


#6

Yes,

Also created a new desktop account with administrator privileges, installed by right click ‘run as administrator’.
manually downloaded plugin, or from within SketchUp and installed trough extensions manager keep active but the toolbar won’t lock after saving and restarting.

However, the included plugins from SketchUp such as sandbox and advanced camera tools get inactive after restart.
These are the plugins that appear floating by default from SketchUp.

The plugins that lock to the top or left by default remain active and in place.


#7

The only correct way to install complex applications like SketchUp in modern versions of Windows is as follows…

As your normal ‘User’.
Close it if it’s open.
Find its installer exe file - probably in your Downloads folder - if not download a new version.
Select the installer exe file’s icon.
Right-click > Context-menu >
"Run as administrator"
If it’s an existing installation choose “Repair” when it’s offered.
If it’s a new installation choose “Install” when it’s offered.
If a “Repair” has failed to fix everything then redo the above steps, when offered choose “Uninstall”, then immediately repeat the steps and “Install”

Installing applications in any other way can cause all kinds of unexpected and unpredictable issues.
Double-clicking the installer exe or choosing to “Run” it is NOT the same as choosing “Run as administrator” - even if you have admin-powers the results will be subtly different.

Also do NOT reset SketchUp to always run as administrator [change it back now!]
With it set up the wrong way certain access to SketchUp is compromised.
For example the drag-n-drop of image-files directly into the SketchUp window will no longer work - this is because Windows Explorer always runs at the basic permissions level and with SketchUp’s permissions elevated Windows Explorer can no longer affect it !

Various su_… RB loader files and their matching subfolders are automatically added to the User’s AppData… Plugins folder, with copies taken from the ShippedExtensions folder, and installs with the main SketchUp.exe in the Program Files tree.
If these are somehow corrupted - e.g. by an incorrect [non-run-as-admin] installation - then they won’t load properly as SketchUp starts.
You also try installing the latest versions of these extensions from the ExtensionWarehouse, install them in SketchUp using the built-in Extension Manager > Install button. The latest versions will then be in your Plugins folder. Note: do not close/restart SketchUp yet, otherwise the [faulty?] ShippedExtensions versions could then overwrite these newer ones you just installed in Plugins.
Open the Plugins and ShippedExtensions folders, and copy the recently reinstalled su_… RB files and their matching subfolders from Plugins into ShippedExtensions.
Now when you close/restart SketchUp the files should all match and be compatib


#8

Would be good for the Sketchup downloader/exe to tell peopel to run it as administrator?
Eg via a popup box?

(im not sure if it does that already,…maybe it does)


#9

Thanks TIG!

My workspace is now saved after restart :slight_smile:

I did as you posted above with perhaps an additional step.

See below how I got it working, maybe it could help others.

First, read and follow TIG’s post. He is TIG!!! :slight_smile:

Fist some general information.

SketchUp pro version 18.
Windows version 10 with latest updates.
Floating toolbar problem was actually a ‘won’t save worskpace’ problem.
User account type on pc just in case, local account type (no Microsoft account linked to desktop or other).

1st try.

Logged into the only account on my pc which has administrative rights (maybe important)
Name of the account is not important but I’ll call it C001.

Following TIG steps ‘run as administrator’ from context menu with repair no luck.

Tried uninstall and install, updated shipped plugins, copied updated from appdata/sketchup18… plugins to programfiles/sketchup18…shipped plugins, no luck.

2nd try.

Looked at TIG post again, maybe he meant ‘normal user’ as in account with no administrative rights. (English is not my native language :slight_smile: )

Deleted Sketchup from the still only account C001 I had on my computer.

Created a new account C002, with no administrative rights.

Logged out of my current account and logged in to the new one.

Downloaded SketchUp, right click context menu ‘run as administrator’ to install SketchUp.

Pop-up appears to give an administrator-password for install because this is account hasn’t got it by default.

Started Sketchup and updated the shipped plugins as TIG suggested.

It to work!:slight_smile:

3th, trying to get it to work on the first account as well.

This is where it get’s weird, for me.

Logged into the first account C001 and installed plugins, problem remains on this account. Logged into account C002 and still works fine.

Logged out C002 and logged into C001 account again and created a third account C003 with administrative rights so I could change C001 account to non administrative rights.

Now I could change the workspace on account C001 and save it.
Changed Account C001 back with administrative rights, added some more plugins with toolbars.

Now the plugins installed while not having administrative rights stayed in place but the plugins I just installed while have administrative rights float and won’t dock.

Again changed the account to non administrative rights, docked the floating toolbars to the top, saved the file,
opened it again and it worked!

Somehow the workspace is only saved when the desktop account has no administrative rights or when these rights are turned of.

Turning administrative rights back on doesn’t affect the already installed plugins and saved workspace.
For installing new plugins and save a new workspace administrative rights has to be turned of again or the account has to have no administrative rights at all :slight_smile:

with kind regards,

Cristian de Kok


#10

i have found solution for your “C001 Account” :wink:


#11

Okay, after a long struggle I think I might have cracked the case after seeing your post.

So far, I have seen the changes of the toolbar/tray behavior depending on the admin rights of the PC.

What I have experience shows that the workspace saves only when SketchUp run on the account that does not have admin rights.

I am going to experiment further and see the results are conclusive.