Toolbars :what makes them stay docked where you leave them? 2019


#1

I just upgraded to 2019 when I open every project that I created in 2018 all my bars are all over the place. I know it does that often when you add one on for a few time that you open Sketchup after installing the plugin but what makes it stop un-docking them? I don’t want to have to reorganize all my bars over and over today.


#2

Toolbar locations are not linked to the SketchUp models at all.

Assuming you installed SketchUp 2019 correctly (right click on the installer and Run as administrator) the toolbars will stay in place where you put them. Toolbar location is not migrated from an earlier version. You have to set them up as you want them.


#3

I have taken the opportunity to re-organize them since I updated but every time I open it again they are all un-docked and floating. It usually does this when I install a new one too.


#4

Probably due to incorrect installation.


#5

I had this issue in the past also and I’m sure @DaveR helped me resolve it that time!


#6

So I can only reinstall (which took me an hour to get all set up and installed with addons) or keep putting them back and checking and un-checking the ones I want on there until Sketchup decides to keep them where I left them?


#7

I too have this issue, never found a solution.

I think it has to do with High Screen Resolution
Having Dual Screens, or dual screens with different resolutions.

I have dual screens with high resolution (3840 x 2160). Only work around I’ve found is re-positioning tools/plugins as you want and saving it as a template. Even then sometimes loading a template has no effect and the process has to be repeated. Re-position and save as a new template… Maybe this will be the update for 2020.


#8

I have windows 7 and there is no other user on here. So I am not sure what else run as administrator does…


#9

Fisrt set your tools and bars where you want on your screen… then see image for saving your template


#10

Oh sorry I forgot to answer. I had tried a template too… :frowning: But now after switching projects enough they are staying put. But I feel like there has to be a better answer than reinstall.


#11

Toolbar position is not part of the templates anymore than it’s part of your SketchUp model.

Did you do as I suggested?


#12

Seems so he said he reinstalled and it its staying put, but wished there was a better solution than reinstalling.


#13

Show where he said he installed SketchUp correctly using Run as administrator.

Your suggestion to use Save as template is not useful. Saving a template does not save toolbar positions.

Since you know how to take care of this problem, I’ll leave it in your capable hands.


#14

Whoa, sorry there DaveR I thought this was a forum. Didn’t think my comments would be received in a negative manner. Sorry I’ll stay out of it next time :pray:


#15

start the re-instal using 'run as administrator ’ and choose ‘repair’…

there are plenty of detailed post on this option…

john


#16

No, as I have deadlines to meet and not an extra hour to reinstall all the extensions and what not. I will maybe have time to try to reinstall Monday.

(My boss would not be happy to dedicate another hour of un-billable time to installing the program again. I was hoping there was something else to be done.)


#17

Repairing the installation shouldn’t take more than two minutes but we’ll see what you get on Monday, then.


#18

Okay between projects I will try that.


#19

Get back to work.


#20

:stuck_out_tongue: Exporting animation. Speed typing allows me to check on forums(it is still work related).