Opening a new reference in Lay out

My new problem: I updated my SU file and added a scene (#14) but it won’t open up into LO. When I closed LO it had saved a previous version of the SU model somewhere on my computer. I thought I would unlink, and purge the link from the document setup, and I even deleted the old version of the SU file, thinking that would make it go by by. So I closed my apps, restarted my computer, and opened the correct version of SU and sent it to LO but dang, it still won’t open with the new version of the model.
How do I ditch the saved file and open the new version without losing all my work?
It has this file name 402881069_BBQ engineering_ 136 - Sketchup Pro 2018
Maybe there is a way to replace this file with my new version?

I searched the hard drive for the file, found it, renamed it, but it still won’t go away.


Unless you unlinked the SketchUp file, the original should have still be linked. Since it appears you’ve broken that link. Go into File>Document Setup>References. Select the SketchUp file listed and click on Relink. Then navigate to the new file and choose it.

Be aware as long as you haven’t screwed up the viewports by modifying their scenes in LayOut, the viewports should update with any changes. You should also be able to select a viewport and change it to the newly added scene.

You are the Encyclopedia Britannica of all things SU and LO - that worked. Thanks Thanks. Thanks.


Now if you can tell me why importing an RTF document loses it’s formatting I can die happy. I typed up this doc. with the scope of work etc, but when I import it into LO it removes the first set of numbers and leaves the second. I can’t upload it as an RTF file - just a pdf.

rtf test.pdf (221.6 KB)

How about uploading the LayOut file including the RTF?

Another tip: as LayOut keeps a copy of your .skp files inside the .layout file, if you completely lose the original .skp you can either duplicate and rename the duplicate.layout as .zip, and unzip it (to then retrieve the .skp you lost). Or you can open the .layout file, and in the document setup references section, where you will see that the file is missing, you can get the path to the working directory. Find your way to that folder, copy the lost .skp to an outside folder, then relink to that file.

I remembered another option. Right-click on the missing model in LayOut, open with SketchUp, Save As somewhere safe, then relink to that file.

When I went to remove the owner’s name - it started working??? So weird. Thanks - I guess the program surrendered when I asked you for help.

I know I would surrender…

There was a list related problem in LayOut, I’m not sure right now if and when it was fixed. But, dragging the RTF into LayOut gave me lists that looked ok, without removing any owner name.

I figured out what is happening.
A) I made a change in my SU file by adding a scene
B) I saved it
C) when I went to document setup/references/relink and clicked on my SU model, it opened up the earlier version because the relink window did not show the later version, so I was relinking to the earlier version.
E) my work around was to rename the revised SU file, then do a search in the relink file name box, and open the new version.
F) my guess is the program is slow to recognize the later dated SU model. Or maybe it is a bug? Perish the thought.
Now, 20 min. later, it has the updated earlier SU file in the list of files.


What you should have done after saving the changes to the SketchUp file is go back to LayOut, right click on a viewport and choose Update Model Reference.

That would have updated the reference directly.

No. It’s not a bug.

I tried that to no avail - it kept opening the earlier version. That’s when I went to the document setup window, which also didn’t work. I then tried a bunch of things, including redoing the Model update from the viewport. However, when I saw it was continually opening the 3:30 pm version, I knew what the problem was.


You must have changed something about it that prevented it from updating the file. Unfortunately it’s probably too late at this point to reconstruct the situation now.

Relinking should always fix things, if the .skp got detached somehow.

Yeah - it now shows the updated version. Sigh.

I wish SU and LO had a bracket tool. Typically when I need some brackets, I will use the dimension tool, and replace the dimension with text. It won’t accept the enter command ( line break?) like the text tool will, so I have to keep the text short.

Show a screen shot of what you are trying to accomplish.

Yes it will accept Enter to make a line break.

Yes you can edit dimension text.


The dimension tool has a number of options. This may be a worthy new topic, do you want to post a new question about a bracket tool?

see what I did here? Nice curvy brackets would have looked so much nicer G

Can you show what you’d like it to look like?

Done with the Dimension tool.

Dese bad boyz:

Or these:

Easily made with the drawing tools. Add to a scrapbook for future use.