Trouble Importing SU file to LayOut


#1

I have used SU/LO for years… now I cannot seem to import or modify update relink an embedded SU file in a current LO document. I get some never seen before link to “ref” deep into some “private” folders…
anyone got an idea What is going on"
I even create a new doc and that doesn’t let me “import” a new SU file…

I am on Mac Sierra… latest version of SU/LO

thanks
aloha
red


#2

Could you share the LO file with us? Or share it privately with me if you don’t want to make it public.


#3

When I tried to upload the LO file… got a notice that the file was too big?

I also though maybe this is on a external HD… not my main HD… would that be the cause?


#4

If the external HD isn’t accessible, then the reference link would be bad. It’s best to keep your working files for both SU and LO on a local, internal drive. I prefer to keep the related SU files in the same folder as the LO file.


#5

Nope that didn’t seem to work… I brought my files to my internal HD… opened the LO Doc from the internal HD…
tried to import from the SU file NOW on my internal HD…

When I endeavor to insert the file… from my Project Folder… and the SU files will not “highlight”

thanks thanks thanks for your quick replies


#6

So in LayOut you are using File>Insert and selecting or trying to select the SKP file? Are you sure it isn’t the back file which has a ~ in the file name?


#7

this is REALLY crazy now… I cannot even update, relink, purge or unlink

when I go to “reference” I get in this bizarre location on my computer… see attached pic


#8

When I endeavor to “insert”… I did it yesterday… the way I would typically… now… this… see in the screen shot…I cannot select my Prelim. Topo Section file…


#9

Why are you trying to select the SKP file out of the LayOut file? You shouldn’t even be in that LayOut file that way.

If you have to use that SKP file, open it in SketchUp and save it somewhere else on your internal drive such as in Documents. Then try inserting it into the LO file with File>Insert.


#10

That is what I thought I was doing… as I save my SU files in my project folder… INSERT that link into my LayOut file
and then when I update that SU file… I typically see that in my Documents folder within LayOut… and can update from there…
I seem now able to insert the SU file on a new page… still screwed up somehow


#11

The files in the large screen shot are the reference files for the LO project. Normally a .layout file is just a zip file with the extension modified. Generally you should have no need to access the contents of that file directly. You can access everything through LO. You should have a main reference SKP file–the one you started the model in and sent to LayOut. When you need to make changes, it should be to that original SKP file and then you update the reference. The LayOut file includes a copy of the SKP file. It gets updated when you update the reference. Again, you shouldn’t need to directly access the SKP file inside the LO file.


#12

Yes, I know that… and that is how it has normally worked… but for some reason… what “appears” to have been saved was a “SU style”…I might have figured this out very obtusely… thanks thanks thanks for being there and your quick replies…
it seems with every new upgrade… I get slammed on some new quirk… I just had a HD melt down and am having to restart everything back… so that might be part of the issues as well

thanks again
aloha
red

I will let you know IF this issue shows up again… bazar… how it happened


#13

Good luck with it. I hope you don’t have any more problems.

d