Referenced SU model listed in red as "missing"

I’m working with Layout 2019 on a mac running el cap. Recently I no longer see the model I referenced listed in blue, but only a layout version buried in my library and listed in red as “missing”. If I click on it and hit edit it finds the model (not missing) and will open it inside SU. This seems to be a chached version and not the current one. I’ve read a few posts on this about a temp folder, but go into great depth on the why and not how to fix the situation. I know have two of these mystery versions of my working model as I attempt to fix the situation (no way to have the model viewports update). Furthermore when I tried to “insert” the model again it defaults to the bogus referenced model which is says is missing. Very disconcerting as deadlines loom. Should I start over with the 2018 version which never had these issues or is there an easy fix?

If the reference file has been moved or the path has been deleted because it references a temp folder, you can choose relink in the Reference panel and choose the current version of the .skp file. That should update things and get you back on track.

If you copy from Sketchup and paste to LayOut you will create references that point to a temporary folder. Copying and pasting is not a good way to get from SU to LO because the reference will be deleted by the OS during regular maintenance.

Also, you should never insert a .skp file into a LayOut file more than once.

p.s. You do cool work! I love the style.

Thanks for the quick response. I grew up with Autocad xrefs so I’m never in the habit of messing with paths, or changing file names. I typically insert the model in layout and then copy VP’s, but I thought I read you should insert for each VP in one of these fixes. Guess that’s the wrong approach. I’ll try the relink approach and see what happens. Cheers.

1 Like

You should insert the file once or use send to LayOut once. After you have the first viewport in the LO project, copy the viewport and paste it as needed to create additional viewports but don’t insert again.

I tried to ‘relink’ and managed to eliminate one of the red references in my library app support folder, but the model is still not updating. I’m stumped. I’m attaching a GD link in hopes you can take a look sometime.

Thanks

Google Drive link

Looking now. It looks like you have two references to the same file which isn’t good. the most expedient think to do would be to relink both of them to the original SketchUp file. The better thing to do would be remove the viewport(s) linked to one of those file and replace them using the other one so you only have one .skp file reference from the model. After removing the viewport(s) from the second .skp reference, purge the LO file.

FWIW, it wouldn’t hurt to purge unused stuff from your .skp files once in awhile, too.
Screenshot - 5_27_2021 , 8_02_20 PM

Actually, at least in Su/LO 2021, relinking both references to the same SU file removed the extraneous link. There are dimensions on the last page that need to be reconnected or replaced.

Thanks. The double reference was an effort to fix the first red “missing” appearance. I’ll plan on deleting all the VP’s.

1 Like