Missing Sketchup Reference - Layout 2023

I have been building a plan set in Layout for several months and today all of a sudden my Sketchup base model seems to be missing . When I opened Layout to work on the plan set this afternoon all of the plan pages showed up blank with red X’s and the default SU style with a blue sky backdrop. Each page shows the Sketchup file as missing with an exclamation point in a yellow triangle at the bottom right hand corner of the page indicating a linkage issue.

Prior to this happening I had noticed that the Sketchup base model imbedded in Layout was no longer the same name as the one in my project folder but had been replaced with a reference file with a long numerical file name. I didn’t really think anything of it, as I was opening the Sketchup file through Layout, and Layout was updating the drawings upon “save & close” of the SU file as expected. But now each page shows the fike as missing and all 20+ pages of my Layout file are showing as blank. My last saved sketchup fis several months and I’m not sure I can stomach starting all of the drawings over at this point.

I always save the Sketchup file when working in layout as that’s the only way it’ll update in Layout. Any idea where the auto-generated SU reference file might be? If I could find it I could re-link the model reference on each page and all of my Layout pages could be restored. I’ve tried everything I could find online and have followed all of the suggested file pathways with no luck. Any suggestions? HELP!


You can re-route the reference in the Document Setup>References dialog. That window also shows the link location. Have you moved any of the associated files?

In the reference section all of my linked files show “missing” in red letters with a blank pathway. I didn’t delete any files between when I opened the doc a few days ago and when this happened.

Make a copy of the LayOut file and open it with an unzipping utility. Are there copies of the references in the References folder?

Where have you been saving the LayOut file? Where have you been saving the references? You aren’t copying the references and then pasting them int LayOut are you?

Are you storing your models directly to the cloud and referencing them from there? Have you moved your model to another folder? Can you try Relinking (again, make a copy of your LayOut file first)?

I made my Sketchup model first and once complete imported it into layou (not sure if I dragged it or used the import function). I built a bunch of sheets in my Layout plan set and then perhaps somewhere along the way either moved or renamed my Sketchup base file. In doing so, Layout made a new reference file with the file name being a “bunch of #'s_file name_bunch more #'s.skp”. I continued to open the base Sketchup file through Layout and working off of the generated Sketchup base file. I’d save my work after each time opening so the changes would be reflected in Layout upon closing Sketchup without knowing where the files were saving to. Then yesterday the base file vanished from my Layout model showing a “missing file error”. I’ve tried everything and can’t seem to find where those files were being saved to???

Now the only base file I have is the original Sketchup file that’s now 4-5 months old and doesn’t have any of the corrections / tweaks that I made while working in layout. I have exported PDF’s of the Layout file from a couple of days ago…but if I relink the old Sketchup file i’ll need to cross check the PDF and re-draw all of the changes that I’ve made over the last 4-5 months. Need to find the location of those Sketchup files that I was saving when opening the file through layout (weird file name with all of the #'s and underscores). Any ideas?



Those are links to my Layout file and the PDF of what it looked like when it had the proper file imbedded.

The elevation file seems to be corrupted, it’s only 340KB:

Do you have Time machine enabled?

Downloaded the .layout file and renamed it to .zip
When ios unzipped it, it went from 29MB to 340 Kb in seconds, which suggests there were a lot of zeros…

That’s just the elevation view on the cover sheet…not the base file for the rest of the plan set. That’s why it’s so small. All of the rest of the sheets in the plan set share the same file though, just not the cover page

There appear to be a lot f unused references in the document. After purging them I was left with two blank link paths. The first one points to the same SketchUp model file as one of the other .skp references. This makes me wonder how you were going about adding references to LO file.

The other blank reference points to an image file which I couldn’t recover.

I opened the GRANADOS PLAN SET .skp file and saved it out onto my computer and then relinked the reference for both the displayed .skp and the blank one. After rendering the viewports on the pages things look like this.

There are some disconnected dimensions but the viewports seem to be OK.

It’s unfortunate that you’ve chosen to not save Camera position for your scenes in the SketchUp file. I’m guessing that’s part of the problem. Whatever you do, don’t make any change to the Camera settings in the SketchUp file without first going through the scenes to fix the camera position and save it which the scenes. Your modeling process in SketchUp really doesn’t make much sense to me with all of your 2D drawings. That also contributes to issues with the LO file.

Out of curiosity I fixed incorrect tag usage …
Screenshot - 9_14_2023 , 4_52_26 PM

… and purged unused stuff from the model.
Screenshot - 9_14_2023 , 4_53_00 PM
It also doesn’t help your model is nearly a mile and a half from the origin.

Here’s the LO file:
GRANADOS PLAN SET Recovered.layout (11.0 MB)
You’ll probably need to reconnect some of the dimensions in it.

Thanks Dave. That model you re-linked called “Granados Plan Set” is the original Sketchup file that I had imbedded in the layout file. That file has a last saved date in May 2023. I have that file on my hard drive and can re-link it no problem. The issue I have is that all of the work I’ve done with the file that Layout autogenerated can’t be found even though I saved each time I closed it, just don’t know where it goes?

The file name that Layout generated was in the format “###########GranadosPlanSet#####.skp”. Any idea where that file would be saved? I’ve checked all of the the Library/Application Support/SU2023 folders with no luck.

As far as the camera goes, I save each view in scenes so if you look at the tabs on the top of the page in that model there are scenes for each sheet with specific layers (tags) toggled on. When I update the scene I just make sure that “update camera angle” is not on. Works great for a plan set like this…

I only had access to the embedded SketchUp model file. I don’t have access to your computer’s drive.

Where is the SketchUp model file with all of that work? Where have you been saving that file?

Relink to that updated file. Select the blank reference line and choose Relink. Do the same for the other .skp file, too. It should condense to a single .skp reference.

It’s saved in the LayOut file’s References folder. You could access that .skp file without opening LayOut as I told you in my first reply.

The problem is, unticking it in Properties to save means the Camera Location is not saved with the scene properties. So later, if you change the camera postion and then try to return to the scene, the camera position won’t change back to what the scene showed. You should be leaving the Properties to Save ticked and, if you want to updaate the scene without updating the Camera Position, untick it in Properties to Update.

Ok. I re-created the problem that I’ve had in Sketchup by creating a new file called “Sketchup Test”. I then imported the file into layout, then moved the file to a different folder. When I re-opened layout and opened the Sketchup file through layout the reference file was now called “2494237301_Sketchup Test_46.skp”. I then saved this file to it’s default location. How would I find this file’s location on my hard drive? I’m using a 24" 2021 iMac running Big Sur OS.

If I can find this file, since I now have a file name to search, I should be able to find the missing file I’m looking for in that same default location for Layout’s autogenerated reference files.

Ok. Found it. And path actually goes to that Library / Application Support / SU2023 / Layout / working / ref folder…but that folder appears to be empty save a few files. Does SU / Layout purge this temp folder regularly? Could that be what happened to my file? If so, any way to recover if I don’t have the exact file name? Already checked the trash…