HELP! Layout has all of a sudden lost all doc references!

HELP! I was making final amendments to a massive document and all of a sudden layout seems to have lost/forgotten all references to my model throughout the document, including my brand etc standard to the template. Are there any workarounds here? I have tried opening up a saved earlier version of the document but it keeps navigating to the latest version where nothing is visible. I also tried renaminig an old version but it is picking up this is the same file. Please help!

Can you share the sketchup and the layout files?

LayOut has internal copies of those files. Do the model and image items still appear on the pages?


No, no images just a blank box with a red cross. It seems to have ‘forgotten’ the link to files that were older than a certain date. I managed to ‘update’ by referencing a new document but then I still had to go in and ‘resize’ each of the image boxes for them to suddenly show up again. I also had to re-do all dimensions as they had turned red :sob:

The file that was the problem was created by a sub-contractor I use so I was not the original sketch-up file author, (even though the same file was copied in my hard-drive on my mac). It’s weird how it just happened all of a sudden. Do you know why this might have happened?

Also I have noticed when I work on Mac that when sketch-up auto saves it doesn’t auto-save to the folder where I save the file. For some reason it seems to default to autosaving in documents folder, rather than the folder on my harddrive system I choose to save the file in. This results in double ups and I have to constantly check where it is saved. This may also have had something to do with it due to possible file duplication? Is there a way to make sure when I do a ‘save as’ and nominate a location on my mac that sketch-up then follows this with auto save instead of always doing it’s own thing and making something new in documents?


This is likely due to the reference file location not being found. Since as you say it was prepared by an outside contractor did they provide the reference files preserved in the same folder configuration. Under document setup/references, the status would state “missing”.

All you need to do is highlight the file and relink to the correct location. You don’t need to redo the dimensions. You just need to reconnect them to the model via selecting all of them and right click.

Resizing the viewports would only be required if proper scene setup in SU was not followed.

More often than not, the “why” here is user input and not the software. LO will not randomly resize a viewport or lose a reference file without help by the user.

Ok, thanks very much for all of this. It seems the contractor must not have inserted the models as I would usually as the models I had inserted from my file were all fine.

Is there a way to stop sketch up autosaving the documents folder on my computer? This is creating double ups of my work.

It never seems to autosave to the folder I direct it to when setting up/ creating the document.

It never seemed to do this on windows but always on my mac. This is definitely some mac problem.


the backup duplicate thing is always in the folder where the main file is.
if the project you’re working on is in a folder named “my super project”, then the backup (with a ~, it’s the equivalent of skb) will pop there.
you can’t have the backups to pop in another place.
and yes, it creates doubles of your work. whenever you save, the old save becomes the backup. that’s the whole point.

the only difference between mac and PC is that on a pc, backups end in .skb while on mac, they end up in ~.skp
but they work the same. in the same places.

if you want to stop sketchup from auto-backup, it’s in your preferences / general / the very first choice.
no more double ups, but no more backup either.

Also note that autosave and backup files are not the same thing. A backup file is created in the same folder as where you opened the file when you save manually. It is just the file you opened, but with a modified name. An autosave copy is created in a separate folder at a specified time interval. You can not specify this folder, it is hard wired.

1 Like


Interesting, yes I noticed it does the back up like you say but for some reason it doesn’t always keep the file reference of where I am saving the files too, and then defaults to my documents, rather than the other folder in my client system I am working on. It sounds like it’s a mac thing. I will ask my IT man if we need to move our client folder tree to documents perhaps.