Changes to SU model aren't showing up in LO...document setup shows missing file

In the document setup box, when I click on the “missing” file name, all of the layers in my Layout show up as being selected (blue boxes), even though they are all locked. I can’t seem to figure out how to get that one to relink and then edit the SU file from it. Changes that I make to what I thought was the linked file don’t show up when I refresh model reference.

when I hit relink on that top file, it goes to this:

It looks like I did a no-no and have two references to the original file? When I click on the one that says embedded, none of the layers show up as selected like they do if I click on the one that says missing.

Having two references to the same file is a problem and you shouldn’t be doing that. Typically it happens if you copy and paste from SketchUp to LayOut or if you insert the file twice. Neither of those things should be done. In your case you effectively have two separate SketchUp files. The embedded one is not linked to your original once you embed it. Obviously that sort of thing causes issues because the changes you made to the original will not carry over to those viewports linked to the emdedded file.

To fix this I would relink the embedded file to the original SketchUp file.

Note that anything you might have done to disconnect viewports from scenes will mean those properties will not update when you relink.

Are you still using SketchUp/LayOut 2019 as indicated in your profile?

Hi Dave, thanks, I was hoping you would be on. So I should open the ref file after hitting relink? And then if I want to make changes to the SU file and have them show up in LO, should I click the ‘edit’ option when highlighting that file after relinking it?

Hi Tracy,

Select the embedded .skp file, click Relink, select the original file you’ve been working on. You could do the same with the one marked Missing. I haven’t tried that in the older versions of LO but by linking both to the same file it may remove one of them so you don’t have two copies of the file in the LO file. (File size should be reduced by nearly half.)

Nailed it! Thanks so much Dave, I’m doing a happy dance here.
Have a great day! Mine is definitely looking up…

1 Like

Excellent! I’m glad that helped. You have a great day, too.

1 Like