On Startup of SKP 2019 - "SketchUp cannot start due to a license error."

Hello all!

Here is the deal. I am trying to open Sketchup Pro 2019 for the first time on a work computer and I keep getting the message in the title. I have uninstalled the program, every previous version, deleted every single SKP related file (License, Roaming, Temp, Local, etc.) and even still when I try to reinstall and open the program, I get this message. I can’t get the program to open at all even to check what license it’s referencing.

I should add, this is a classic single-user license

Any suggestions? Am I somehow downloading the wrong version?
Let me know if I need to provide some specifics.

Thank you!
-Sam :stuck_out_tongue:

Did you install with administrator priviledges?

Did you delete the (possibly corrupted) license file in “…/Users/Public/Application Data/SketchUp/SketchUp 2019” ?

1 Like

Let me try it out. Be right back!
Thanks for the speedy reply.

What format is the license file in?

SketchUp.lic

So if I haven’t even opened sketchup to put in a license, will I find that .lic file in there?

Okay I deleted the .lic and still get the same message on startup.

That is again after a clean reinstallation? For starting, SketchUp always needs a licence file, be it SketchUp Make (accepted non-commercial terms) or SketchUp Pro (license key). During a clean installation, the license files are put there.

Yes, clean installation of SketchUp Pro 2019 as administrator from this link. It’s bizarre because it won’t even initialize, I just get that message immediately. I tried opening Layout and Style Builder and got the same thing.

I did some digging and found the license manager page and can see a few of the licenses we own are on “HOLD.” Could that have anything to do with it even though there shouldn’t be one associated with his SKP2019 yet?

“on Hold” means that an old license was auto-upgraded to the latest version and will cease to work (single user license) or cease to work after 60 days (network license) as soon as the latest version gets activated.

besides the Trimble license server being down… an active internet connection w/o a password protected proxy and w/o a firewall blocking neither “sketchup.com” nor “google.com” (the latter for the being online check) is required.

Limited user rights blocking to write user data to the concerning Windows user directories? Try if launching SU itself by “right-click > Run as Admin” helps.

Being logged in to the appropriate Trimble ID is obvious.

1 Like

Tried it all but thank you!
I’m talking with a Tech now. Will update with solution.

Any luck on this, I am having the same problem. I have update half a dozen computers with the very same install file without any trouble, except for this one. The previous install of 2018 still works fine.

Thank you for the information you’ve provided so far. We are working to get to the bottom of this.
If you have run into the “SketchUp cannot start due to a license error.” Please let us know what sort of system you are running on.

  • Mac
  • Windows PC

0 voters

Hi, any updates on this. We have many users but at present it just affects me. I have tried all of the above remedies but to no avail.