SketchUp cannot start due to license error

Anyone else have this problem? New Maintenance & Support for SketchUp Pro 2019, purchased 2/22/2019. Downloaded and installed results in

“SketchUp cannot start due to Licensing error.”

I found a reply from db11 that advised removing / deleting SketchUp Licensing files:

Windows - C:/Users/User/AppData/SketchUp/2018/2019

then deleting the SketchUp folders.

Uninstalling

Then

Reinstalling

This allows opening SU and authorizing with serial # and authorization code.

SU opens and appears to be OK.

Exiting SU then trying to open SU results in the same error message -

“SketchUp cannot start due to Licensing error.”

I removed the folders two more times with the same results.

I have received three emails from Front-Line Support

Two advised uninstalling then reinstalling using Administrator Privilages

All with the same result

Front-Line Support reply’s they are baffled and are elevating to Tier-3 Support.

To date have been unable to speak with anyone. Attempts to contact require providing Maintenance and Support # and registered email. Complying results in Contact form proclaiming Success! You are entitled to maintenance and Support with no provisions for doing so. Phone number provides a phone tree that sends you to phone mail.

So very frustrating.

Sorry for the rant

If you do not add the license, what do you see?
Since the trial period isn’t over, you would be able to use the program.
Be it logged in with the Trimbe ID created, or another.
Do some stuff, save a file and quit.

Start SketchUp again, and try to add the license, now.

SketchUp 2019 Professional will not open. Clicking on SketchUp logo to start program results in “SketchUp cannot open due to a License error.”

We’ve started up a poll to collect additional information on this issue. Please go to this post and answer the single question poll: On Startup of SKP 2019 - "SketchUp cannot start due to a license error."

Ok! I think we found the culprit. It looks like Realtek HD Audio Manager is causing the “SketchUp cannot open due to a License error.” issue. The workaround, for now, is to go to open the Windows Task Manager, click on the Startup tab, scroll down to Realtek HD Audio Manager, right click on it and select Disable. Save your change.

The next time you reboot your computer, SketchUp should launch properly. If not, let me know and we’ll dig some more.

1 Like

I’m extremely curious in how Realtek HD Audio Manger can affect SketchUp licensing.

2 Likes

I thought exactly the same thing, but it wouldn’t be the first time that audio bloatware… er software has interfered with SketchUp. ASUS Sonic Studio, as well as the Nahimic Service, has caused problems in the past as well as Duet and for some, a version Grammarly. Wish I had a better understanding of how Realtek Audio Manager messes with our license manager, but that’s a rabbit hole I’m not ready to dive into. I just report it to the QA team.

1 Like

I am intrigued too. I wondered about ports at first, but sound drivers worry about I/O ports, and SketchUp licensing worries about TCP ports. Just happens to be the same word.

2 Likes
1 Like

I have Sonos installed on a Macbook, if I enable messaging, the sketchUp cursor always changes to the select icon when a new song starts, but the tool function itself does not change!

1 Like

Many times, when troubleshooting bizarre issues like this one, we don’t get very many patients… in this case Dell computer owners. When we do find an example that we can remote into, we have to be quick and gentle. We don’t have a lot of time for experimenting and we are limited to a low level of lateral thinking (methodical, “reckless abandon”) that we can use when we approach the issue; and, with that back story… it looks like My “fix” reverted back. We rebooted and things worked again… Maybe a reboot was the solution all along.

I will continue to monitor this. In the meantime be sure to get the new SketchUp Pro maintenance release that came out yesterday!

Just hit this problem. I’m running SketchUp Pro 2019 on a Surface Pro 3. Haven’t started the app since the latest Windows 10 update.

When I tried today I got this error. Tried disabling the “Realtek RtlService Application” which is the only Realtek service I see in Task Manager.

No change in behavior. Any other ideas?

By the way, my business is at a standstill until I can get this resolved, so it’s rather urgent. I have submitted a support ticket as well.

***Update ***
My copy of 2018 still starts just fine - not that it helps me at all…

Jeff A.

I tried this on a users computer but no luck. Is something supposed to happen after double clicking the file?

I tried this with a customer, and also nothing appears to happen, and SketchUp still shows the error.

Hi, I too am having this problem.
I have deleted all older versions of SU (2015 & 2018) on my laptop. I have also deleted Realtek HD Audio Manager as instructed in this thread.
I have purchased SU 2019 on my pc which works fine and now I would like to add the same version to my laptop (I believe you can use SU on two devices). I’ve tried installing SU 2019 on my laptop twice now. I’ve re-started my laptop after each install but still get the message “SketchUp cannot start due to a license error”. Any thoughts anyone???

In my case the problem was “Google Earth Pro” Uninstalled it, and everything was back to normal again.

1 Like

@colin Google earth?

If you reinstall Google Earth Pro, do you get the license error again?

Did not reinstall ‘Google earth 2020’ after that yet. But as soon as ‘Google Earth 2020’ was uninstalled ‘SketchUp pro 2016’ was functioning again on the next launch.