SketchUp cannot start due to license error

This topic has been about a “cannot start due to a license error” dialog that appears as soon as you open SketchUp 2019 and 2020. Is that the error you saw in 2016?

@CrrWllr More questions, you first called it Google Earth Pro, then Google Earth 2020. Are they the same thing?

Did you install Google Earth Pro recently, or were you an original subscriber when you had to pay for Pro?

Google Earth Pro 7.3.3.7673 x64 April-2020 Latest version it’s FREE.
The error is: “SketchUp cannot open due to a License error.” along those lines, with not much detail in the dialog box.
I updated from the 2019 version of Google Earth.
Google Earth Pro 7.3.3.7673 x64 April-2020 was running fine only SketchUp 2016 was not opening.
Tried uninstalling other apps, Reinstalling SketchUp but to no avail, then remembered I had installed “Google earth” two days earlier.
Uninstalled it and “SketchUp 2016” was running again.
Just a heads up, see if uninstalling other Google app you have installed besides “SketchUp” solves the problem.

Hello everybody, i my case, i deactivate real hd audio, i uninstall google earth, but same problem…

The only two solutions at the moment are to reinstall Windows, or to run SketchUp 2018.

Hi,

I just received the same notification on starting my laptop.
I opened Sketchup in administrator mode and everything worked fine…

Bye,
Bjorn

Did you mean right-click on SketchUp itself, and run as admin?

Also, do you predictably get the error if you run normally? There is a variation of this problem where just a reboot is enough to make the error go away.

Hi Colin,

In attachment you’ll see a screendump with programsbar on top.

What happened was this:

  • I tried to open a Sketchupfile by double-clicking on the file (I am a pro-user, never any problems)
  • I got the notice ‘SketchUp cannot start due to license error’
  • I tried to open via a left(normal)-click on Sketchup-icon in programsbar
  • I again got the notice ‘SketchUp cannot start due to license error’
  • I then clicked the same Sketchup-icon in the programsbar using right-click,
    selecting ‘open as administrator’
  • After a long wait (was Sketchup readjusting something?) Skecthup popped up,
    everything working as normal
  • I closed Sketchup

Without rebooting I double-clicked on a Sketchupfile: everything worked fine

Did my ‘Adminstrator’-start, revamped something? No idea? I had the double notice,
did a simple thing and everything is apparently back to normal.

Hope this is helpful.

All the best,
Bjorn

administrator.pdf (167 KB)

Your PDF seemed to be a massive screenshot to show me how to run as admin! It may have been more, that I’m not noticing, But otherwise, take this as a tease and not a criticism!

I did get to test the idea on someone, and it wasn’t the solution. Your case may have been different. If your run as admin idea had worked out, I was going to suggest we send you huge reward.

1 Like

Hi Colin,

I have no ambition to win awards or anything. I just had this specific
problem (twice) and did what I did: worked for me.

Sorry that you thought I was luring you into some SKP-magic-solving-scam…

Your earlier question suggested you not understanding what ‘opening as
administrator’ meant. Equally daft for me to think that you could not
fathom my previuos remark…

Sorry and all the best,
B

It would have been a good award. One thing about your case compared to most of the ones I’m trying to fix, for those people the problem doesn’t come and go. It fails to work from the first clean install of SketchUp, and nothing except changing computers fixes it. I haven’t yet had a volunteer willing to reinstall Windows to see if that helps.

I reread what I asked about admin mode. You’ll find a lot of comments in the forum where DaveR and others query someone about run as admin, which the person swears that they did, but it turned out that they were running Windows under an Admin account. I was just making sure that the admin mode you meant was run as admin, and not just being in a Windows Admin Account.

Hi there, I’ve been using sketchup for years, with pretty much no probs and just started getting ‘sketchup cant start due to license error’ message. I’ve tried everyting I can find in this forum, and elsewhere to resolve and still banging my head against a wall. Any chance you could send me a license for 2018 so I can get an assignment done ? Thanks, Tadhg

I found your support request, and replied to that message.

This is a repeating problem - cannot log into my subscription - AGAIN - and have deactivated autorenewal. I need a reliable access, Anyone figure out the solution to:

Unable to connect
Firefox can’t establish a connection to the server at 127.0.0.1:55581.

I read through the various problems you’ve had before, and seen what my colleagues have suggested.

Something I don’t see in the list is to check if Firefox is having general problems with localhost.

One thing worth trying is to replace the IP address with the word localhost. So, if the page that is failing to work says 127.0.0.1:55581, change that to be localhost:55581, then press Return.

I see from your support case emails that you like Firefox and Opera, and how Opera uses Chromium like Chrome does. Both of those browsers work ok for me, and I think that you have tried Safari in the past as well.

For Firefox, I found this discussion about fixing issues with localhost:

https://support.mozilla.org/en-US/questions/1011967

Given that you’ve tried a few different browsers, it may be a system setting or network issue. Could you do a test where you use your phone as a hotspot, and see if that works? That would quickly rule out your WiFi router as being an issue.

If you do choose not to renew your subscription in four weeks, and fall back on your SketchUp 2018 classic license, that also needs a sign in to use some of the features, but at least it doesn’t use a localhost server in order to sign in.

Your reply today will go back to James, but I doubt that he will read it until Monday morning. I will let him know about any progress we make in this forum discussion.

Tried replacing with “localhost” without success. Also tried using my phone as a hotspot–no luck accessing my Sketchup Pro subscription.

I asked what caused this last time but do not see a response. It was fixed at your end, so I hope this can be done again. And, I would like to know why this happens and how to prevent it so I can feel safe to extend my subscription.

John

Collin/James: appreciate your response, but as noted above, no luck. Pertinent (to me) is that there has been no change in my home network. That is, the router cannot be the problem as I had not problem several weeks ago, but do now. As you’ve observed, I have tried a number of browsers to complete the login (why and I asked to do this all of a sudden?) and all get stuck. I am reasonably tech savvy, but not a techie and would need coaching if there is something to do at my end. As this is about getting a subscription working, I would hope that expertise at your end can be brought to bear.

Thanks for your assistance.
John