On Startup of SKP 2019 - "SketchUp cannot start due to a license error."

Did you try contacting Customer Support?

A quick update on this. The dev team has this issue as a top priority. The problem is we cannot recreate it in house (as often the case with software companies). It is not related to classic or subscription account types. It seems always an issue with Windows systems. It is mostly reported by Dell users, but there are a handful of others. I’m at the point where I’d like to see if I can get an image of a user’s hard drive, buy a computer of the same make / model / specs, image that drive with the customer’s image JUST so we can have a system to experiment on. If you’re system is exhibiting this issue and you are going to be in the Northern Colorado area, please reach out and we can show the team.

P̶o̶s̶s̶i̶b̶l̶e̶ new workaround
We are theorizing that the issue is related to Windows update 1903 and a corruption of the Windows user profile. This update has caused a number of headaches for folks, but hasn’t affected everyone. For those of you with SketchUp Pro 2019 who are seeing “SketchUp cannot launch due to a license error”, would you mind giving this a try.

  1. Create a new Windows user account by following these simple instructions: How to Create a Second User Account in Windows 10 | Webucator
  2. Log out of Windows and back in as the new user
  3. Try launching SketchUp Pro 2019
  4. If it works, try logging out of that account and back into your main Windows account. Does SketchUp Pro 2019 work?
  5. If that helps OR doesn’t help, please let me know.

Windows 1903 update seems like it could be a red herring since we’ve recently seen a couple of examples if this error on Windows 1803.

A small update… I’ve been present for 3 fix attempts using the above suggestion and none of them worked. I have heard that an in-place upgrade worked for one user, but there are risks. Find out more about this suggestion here: https://www.computerworld.com/article/3262979/how-to-fix-windows-10-with-an-in-place-upgrade-install.html

I would try the Windows user solution, but I’m running Windows 8.1, not 10. I have a Dell (Alienware) laptop. I just attended a two day training workshop through SU Trainer where the program worked. I came home and tried to open it and I got the license error code. I too reloaded the program and Windows said it was
fixing the corrupted files with the reload but this did not work.

Good afternoon!

Just wanted to throw some extra info in here, if it helps the troubleshooting process.

I have one user at one of my client offices that is having this issue. I had her restart the computer, and the issue went away, however, she just notified me today that she has to restart pretty much every day because whenever she uses sketchup, she gets this error. The workstations here are set not to sleep, so it’s not a sleep/wake issue. The restart fixes it for the day, but for some reason, it comes back the next day.

I hope this helps in any way.

Interesting. The first thing I did was restart and it had no effect.

I have had a customer report that the error went away when he updated to Windows 10 build 1909. I have done that update on my machine, but I was never able to show the issue, to know if 1909 really helped.

If any of you are still seeing the issue under build 1903, and were thinking of updating to 1909, let us know if it helps with the license error.

Just started SketchUp after a few days of not having it open. I’m getting the License error message. Tried a reboot and the error persists.

Lenovo Z70
SketchUp Pro 19.3
Windows 10 Pro
Build 1903

Repaired Sketchup Version 19.3 and SketchUp now starts successfully. One thing I did notice during the repair were that some libraries were required to be installed. I’m not savvy enough to understand why they would need to be installed when SketchUp were running originally ok. But I think it’s worth pointing out.


Somehow those Visual C++ libraries had been removed, or perhaps one of the later libraries. SketchUp needs either those specific ones, or the libraries that include the “14” version. It gets somewhat confusing, because the 14 isn’t tied to a year, a few different years of the Visual C++ libraries had 14.x version numbers.

I have just encountered the cannot start error, this was after removing another App.
After looking at this thread I took a SWAG and did a repair of the Visual C++ libs for 2017.
I am able to open SU again. BTW the bit about the Realtek audio driver, I do not have it on my system

What was the repair that you did? As a fix for a different I have people remove the 2015 and 2017 versions, then let SketchUp install the 2015-2019 version. Would be very handy if that also fixed the license error problem too.

Strictly a repair, it is my understanding the 2017 version replaces 2014 and maybe 2015

With one of the versions being called 2015-2019, I think that was a combo version that had all that was needed to support 2015, 2017, and 2019. Having 2015 and 2017 installed already, then adding 2015-2019, could have some duplication in it.

I have versions for '12, '13, then it skips to 2017.

In a recent case where removing the later ones and installing 2015-2019, that user had 2013, 2015, and 2017. That was true for me too, but I wasn’t seeing any issues.

I’m having the same issue (license) on an old laptop running Windows 7 professional - it’s a machine for our elementary aged children. I’ve just uninstalled and am attempting a reinstall of SU 2019 Pro - subscription. To my knowlede this was the first time any version of SU has been installed. Will keep you posted on results.

Hi, @TheGuz.
I’m Roberto of Omnidea, SketchUp Italian reseller and extension developer.

I’m experiencing the "SketchUp cannot start due to a license error” with a customer of us.
I’ve tried everything suggested here in a TeamViewer session but I still get the error with both 2019 and 2020 licenses. SketchUp Pro 2018 works fine.

Please contact me for details.

HI, @TheGuz.
Can I get a reply from you?
I’m not allowed to send you DM.

Hi Roberto! Apologies for the late reply. I’m a bit out of the loop on this issue as I have changed departments. I would recommend reaching out to the support leads on this subject and they will be able to give you the latest recommendations.

1 Like