Numpad decimal separator input not localized

keyboard
decimal
localization

#1

I am using the French version of windows 10.
The decimal separator in French is comma: “,”.
In SketchUp the decimal separator is localized, so SketchUp uses comma as a decimal separtor on my system.
In most localized applications, eg. Excel, the dot “.” key from the numeric keyboard inputs the localized decimal seprator (in this case a comma).
However, when I type a dimension using the numeric keyboard in SketchUp, it is a dot instead of a comma that is input. This renders the dimension invalid, and I have to edit it and insert a comma from the “regular” keyboard area. Very painful!
If this can’t be fixed, is there a way for me to switch to English localization for SketchUp?


#2

Hi Geoffrey, hi folks.

I have signalled this since version 4 or 5. On PC, the dot on the numerical keypad works as you describe. On the Mac, there is no problem. On Mac, SketchUp behaves as Excel and other softwares and transform the dot as required to a comma if the regional settings are set for that.

Regards.

Jean