Issue with Keyboard Layout Sketchup 2023 - dot and comma

I am with US keyboard (Logitech K860) but use both US and Bulgarian layout.
Sketchup do not recognize the “dot” in NumPad like comma when I type in US. All other programs on my PC do it.
When I type in Bulgarian Sketchup recognize the comma instead of dot, but do not recognize the shortcuts like: L (line), R, P… all. However in preferences it recognize and convert any bulgarian sign to US for shortcurts. Also I can write text in bulgarian.
I’ve tried to change “dot” with “comma” in Windows 10/ regional / keyboard / languages / US / advanced options … but this work only one time. When I close Sketchup I must repeat this action before starting Sketchup again.
Does anybody have an idea what can I do to repair this.

you’re probably suffering from the same problem as the french
(no, not ego, the dot/comma problem)

that’s what I ended up doing on my PC, as I mostly use it for SU (and for classes), although, it’s weird your computer don’t seem to keep the info. maybe the switch from US to bulgarian layout is causing the reset ?

from what we understand, the decimal key in the numpad reads as decimal key. if you set your computer to use a comma, then it’ll read as a comma. (like in most of europe)
But in Sketchup, since probably version 7, this key is read as a dot, no matter what parameter you choose.
therefore, when using a SU version in a language that uses commas (french, apparently bulgarian) you still get a dot. then only way to go around is to ask windows to use dots for decimals. or to use actual comma.

SU is the only software I’ve met that does that, read the decimal as a dot key regardless of the user’s choice.
In July, colin mentioned an existing bug report on this, no news on this front since.

I have Spanish keyboard and I configured it on the Windows setting to use the dot as decimal separator. On MacOS there’s no way to change that, at least I don’t know how to do it.

1 Like

There was a problem with Russian and Ukrainian keyboards that we have a fix for. In a quick test it looks like it should help with Bulgarian. I can’t yet tell you when an update will come out to solve that problem, but when it does there won’t be an update to SketchUp 2020, only the latest version will get the fix.

2 Likes

yeah, it seems that for languages that use a comma as a decimal separator, if you want to use the decimal key of the numpad, you have to do this. it looks like the key is hardcoded as a dot in SU, while SU still understands it needs a comma in some cases.

Capture d’écran 2023-10-09 à 15.34.33
if you really want your mac to use a dot and not a comma, it’s in the general preferences, under language and region. by default it’ll use the default symbol of your chosen setting

but on mac, the issue is not here. the decimal key on the numpad will give you the expected decimal symbol you picked, and SU will read it as such.

1 Like

I didn’t know, thanks for that.

There is an update posted, that has a few keyboard related fixes in it. Here’s the release notes.

https://help.sketchup.com/en/release-notes/sketchup-desktop-202313

1 Like

Well, I’ll go check immediately, got a day of training tomorrow :slight_smile:

edit : nope :slight_smile:

the decimal key still prints a dot. regardless of my decimal symbol choice in windows.
therefore, if I choose a dot, it’s fine, if I choose the classic comma, the decimal key is useless again.

what’s weird is, it’s not just SU.
when I ask windows to give me a comma for decimal, the decimal key will give me a comma in firefox, google drive, libreoffice (more recent openoffice).

BUT not in SU or in the notepad. and that puzzles me. As if windows still treated the decimal key as a dot no matter the localisation choice, and left it to the apps to pick weather to show a dot or a comma.

I ended up installing Microsoft keyboard layout creator. Took the existing French layout as a base and surprise, the decimal symbol is a dot, even on a french AZERTY.
Switched to a comma, as it should be, saved it, and now in my language properties, I can choose French or French custom (with a comma)


So now, I’m wondering, is it always a dot by default, and windows leaves the choice to the apps ? explaining why firefox saw a comma and notepad a dot ?
Or does it depend on the keyboard, my laptop only has a dot symbol, my logitech has both.

The plot thickens.

1 Like

The dot and comma problem may not be any different, the fixes in the update were more about shortcuts and non-Roman keyboard fixes.

2 Likes

I have downloaded the new version, and the period key (.) now works as a shortcut again.

I just upgraded from 329 to 340 and it has disabled all input from the numpad (uk keyboard, US english language selected), i went up to the hot fixed version released yesterday and its the same issue.

Sketchup takes input from the numpad when in a menu option, but not as a shortcut.

2022 this works ok as expected.