Line thickness multiplier in animation export

Hi,

In the animation export options, I can’t set a line scale multiplier with a comma.

I can set 1 or 2, but not 0.5.

I’ve tried with the point and with the comma, but in all cases, the numbers are accepted, but not the point or the comma.

This problem is present on version 2023. Version 2022 allows me to use a comma.

Please note that I’m working on a French version.

When exporting in image format, I can put a factor with a comma, but not for animation.

Have you also encountered this problem?

Thanks

Eric

No one has encountered this problem?

Thanks

encountered no, I rarely export animation with a decimal in the line multiplier on my pc :smiley:

So yeah, I tried, french version too, same problem.
I wonder if it relates to the classic decimal point on some non english version problem.

The line multiplier field still expects a decimal dot even if your computer is in non english (or american) parameters.
However, it won’t accept shift + ; to place a dot. it expects you to use the numpad decimal key.

If you don’t have one, you’re done. if you’ve remapped it to force a comma (as I did), you’re done.
(I also tried typing 0.5 elsewhere and pasting it but the field really don’t see key combinations)
I guess it would be an easy fix, simply have the field use the decimal symbol of windows and not the american dot.

ping to @colin who is probably eating turkey leftovers this weekend, so he can pass it on :slight_smile:

I would guess that is because a computer screen has no half pixels. Line widths in SketchUp are measured in screen pixels.

the with multiplier is not pixels, it’s a factor.

a line in SU is 1 pixel. by default, x1 will keep the ratio between your screen size and the line size.

If you make your video twice the size of your screen, the lines will remain the same ratio. if you want thinner lines, you’ll need to put x0,5 ratio

I just tried on mac, a 4k video, x1 and x0,25
it works.

here it’s an issue of text field being obstinately american :stuck_out_tongue:


here is a test, 4000x2000 px image export, left is 1x factor, right is 0,25x factor


and this is 2000x1000 px with 1x ratio.

1 Like

Thank you for confirming the problem.

The screenshot of the first message clearly shows that you can enter a value with a comma or a dot, since SketchUp indicates that you can enter a value between 0.25 and 100.
And in version 2022 it works.

I don’t know if there are any other decimal separators in the world apart from the dot and the comma, but it would be nice if SketchUp automatically accepted both, so that the user can choose what suits him best rather than having to look for the decimal separator set in the operating system.

So it does look like a bug.

it does indeed. :slight_smile:

Ping to @colin we’ve got a simple localisation bug here, SU expects a dot even if the PC is set to use a comma.
But won’t accept a shift + ; in order to make a dot. At least in the french PC 2023 version.
Mac is ok. so is 2022

But won’t accept a shift + ; in order to make a dot.

Sure, but if you have a numeric keypad, there’s a key that allows you to make a dot directly.

Sure, IF you have a numpad. and your PC is configured to have a decimal dot.

Also, well, it’s part of the other issue.
The numpad decimal key should give a decimal symbol, not a dot. this is a very old problem in non-dot countries that has never been addressed by Sketchup. Every couple of years it resurfaces, and then, it’s not solved.

So let’s ask @colin .

When will SketchUp be able to handle decimal separators better? :yum:

Problem still present in SketchUp 2024 :unamused:

:wink: