Decimal separator input problem with SketchUp on Windows

This post, by SuperS06, dates back from October 2016

I have singnaled this problems since SU 7.

When will it be addressed ?

Is there perhaps a difference between French and French Canadian localization settings? I have the reverse problem with AutoCad - my Finnish keyboard produces consistently a comma from the numpad and AutoCad requires the dot (full stop) to be used regardless of location.

I’ll add that SU is the only software I’ve used on PC with this issue.

on EVERY software, the numpad separator will give me a ,, but not in SU. it will ALWAYS give me a .
BUT it’ll require a , to work, making the numpad useless.

And befor someone asks “have you tried to go to the windows parameters and change the decimal from , to .” yes, it works. the numpad still gives a . but at least it’s recognised. The problem is that your whole PC now uses a decimal dot instead of a comma.

I wonder if it has to do with the french keyboard layout, since french canadians and belgians use a version of qwerty (we use azerty)

I don’t remember much from my SU class late 2007, but that I remember. The professor telling us to be careful about decimals.

1 Like

I don’t think that AZERTY vs QWERTY makes any difference.

I tried with my Apple bluetooth keyboard that has a numpad and I have no problem getting a , as a decimal separator. In fact, there are two symbols on the key, a dot and a comma while on my PC there is only a dot printed on the key, no comma.

However, I get a comma with that key when using Excel on the PC. This makes sense.

With Word, I get a dot. This makes sense.

nope :slight_smile:

we don’t have any issues typing stuff in inches or feet. Most of us don’t do it because it’s silly, the meter is a french invention after all :stuck_out_tongue:


it’s a numpad issue.


here is one, on a (old) french PC keyboard. the decimal appears to be a dot (printed on the keyboard)

But if I were to use any software with a default french windows installed, it would appear as a decimal comma. because in france, as in many countries, the decimal is a comma.

so it would type 1,265m or 14,56" with a decimal comma
but not in SU.
in SU it will write 1.265m or 14.56" with a decimal dot
problem is, SU, in france, expects a comma. therefore it returns a red message - length invalid or something. And we have to manually input an actual comma as if typing plain text. we can’t use the decimal key in out keypad.

As I said, a solution is to tell windows to use the decimal dot instead of decimal comma, but then it’ll do it in every software, and a decimal dot is not the standard in france (and parts of europe), some softwares won’t recognise it as a decimal, they expect a comma.


so right now, and for the past 15 years, on a PC, either we type an actual comma, or we ask windows to go decimal dot for everything. just because of sketchup.

Funny thing is, the decimal comma is used by a lot of countries. Italy, Germany, yet the italian and german versions of SU don’t seem to present this issue (or at least they’ve never complained about it).
Since french have an AZERTY layout different from the QWERTY that italians or german have (they have local variations), I’m again wondering if it couldn’t be related.
basically, on every keyboard, every languages, it’ll give you the good decimal symbol, but in french, it sort of reverts to default and gives you a dot ?


no issue on a mac. first, my keyboard (and all the keyboards I’ve ever had on mac) have both comma and dot on the decimal key, and either apple or the mac version of SU seems to type the expected decimal symbol.

Thanks, I had answered the wrong post. I will put my answer in the right one now.

I will ask about the numpad oddity with SketchUp.

I did find the bug report about this, and added a note to point out that it’s still an issue in 2023.

2 Likes

Thank you Collin. I have been signalling this oddity for a looooooong tine

I wonder if this bug can be reproduced with a qwerty keyboard set to french, or if an azerty one is needed.
(if they can’t reproduce it, it might be needed)

I bet it’ll one of those very hardwired things for whatever computer standard numerical system is used and is probably not feasible to change without breaking everything.

In the same way that many databases have been made in such a way they can’t accept anything beyond standard english characters and cause problems if you have a spanish or nordic character in it.