Any chance to change the , use for . in SU?

decimals
decimal_separator
numeric_keypad

#1

Hy,

Is there a chance to change the , by th . in SU units value.
It will be a Fabulous thing to use numeric pad.


#2

Howdy,

I’m assuming you want to change the representation of decimal numbers from xxx,yy to xxx.yy. This is actually an operating system function having to do with localization. It sounds like your computer is set to use a comma as the decimal separator (between whole and fractional part) and the period as the thousands separator (one Million being 1.000.000) - but you have a keyboard that assumes the opposite!

In Windows 10 (per your profile), you want to:

  1. Navigate to ‘Control Panel > Clock, Language, and Region’.
  2. Click on "Change Date, time, or number formats (Under the “Region” heading)
    This will open a pop-up dialog
  3. Click on “Additonal settings …” button - this will pop up another window
  4. Be sure you are on the “Numbers” tab - it should look like:
  5. Change the “Decimal Symbol” to a period
  6. Change the “Digit Grouping symbol” to a comma
  7. Click “OK” (Customize Format window will close)
  8. Click “OK” again (Region window will close)

You might have to then restart SketchUp - or restart your computer to have the changes take effect.


#3

Fantastic! @sjdorst .
Worked liked a charm. Great.

Windows is a strange world. Do u know if u want to turn Numpad on , in Windows10 u must be a guru in regedit? Just to start Windows with numpad on…

Well unless u know a path…:wink:


#4

Actually, on my Windows 10 machine, it remembers the keyboard state (Caps Lock, Num Lock, and Function Lock - which lets me have a 2nd set of F key meanings) anytime I reboot or power cycle!

So sorry, but I don’t know a path. :slight_frown:


#5

I´ve been searching the Net. It seems need to edit regit and keys of registry… Really don´t understand that logic of today software, one step in front two steps back.


Under the hood of Windows tech problem - preserve Num Lock state across reboots
#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.