No scale-units to choose from when trying to print to scale

sketchup
printing
windows10

#1

I need to make some views off my project with a scale of 1:100. I read the tutorial (on this site) on how to print to scale and followed those steps. However my print preview screen does not give me any units to choose from (inch, mm, m etc.), as you can see in the image below. When I add them manually it does not work and it gets printed to fit the page, even though i have not checked the option ‘Fit to page’.
I’d like to know how to fix this, how do I get those units to appear?


#2

What tutorial?
Did it say to adjust the camera setting?
Try Camera>Parallel


#3

You wouldn’t be able to set a scale for the print out if the camera is set to Perspective but you should have numbers in those fields.

This looks like it’s possibly due to incorrect installation of SketchUp or it could be a driver issue. When you installed SketchUp did you right click on the installer exe file and choose Run as administrator? If you didn’t do that, you should do that now.

Do you have a real printer mapped to your computer? What do you get if you select that printer instead?


#4

I am in parallel perspective and in one of the standrad views.
The tutorial I read: https://help.sketchup.com/fr/article/3000154 (wasn’t literally this site, apologies)


#5

What do you mean by ‘numbers in those fields’?
The answer on your second question I don’t know anymore, it has been some time since I downloaded Sketchup. I’ll give it a shot. Do you think it is a good idea to upgrade to 2018 Free then? I am still using Make 2017. I guess that shouldn’t be the issue here, though.
On my normal printer the same issue occurs.


#6

Those blank fields in your Print window shouldn’t be blank. There should be some numbers in them even if the camera isn’t set to Parallel Projection.

And you should be able to set the scale if it is set to Parallel Projection.

[quote=“Baksteen, post:5, topic:69466”]
The answer on your second question I don’t know anymore, it has been some time since I downloaded Sketchup. I’ll give it a shot. [/quote]

It’s worth a try. If you don’t still have the installer, download it fresh from sketchup.com/download/all

There is no SketchUp 2018 Free. There’s SketchUp 2018 Pro. The current free version is the web based SketchUp Free but it doesn’t have an option for printing to scale.

No. SketchUp 2017 Make should still work fine. The only reason you shouldn’t use it is if you are using SketchUp for anything other than hobby use. Make and SketchUp Free are not licensed for commercial use.


#7

Those fields certainly are blank, no matter what options I chose.
Thanks for your quick answers, I’ll try re-installing later this evening. Will keep this updated if they work out or not.


#8

When you re-install, choose the Repair option. Good luck.


#9

Reinstalled Sketchup Make 2017 and chose repair option, sadly didn’t fix the issue. Reinstalling it completely also didn’t work.
I guess I’ll have to make screenshots and scale them in Adobe Indesign. You lose a lot of quality that way, though, so if somebody else knows a fix that would still be appreciated a lot.
Also, come to think of it, the first time I used this method it did work just fine. However, after that first attempt, which failed because I did not crop the view enough, I got this problem everytime. This seems to inidcate it is possible with the drivers et cetera I currently have.


#10

Did you right click on the installer and choose Run as administrator or did you just double click on the installer?


#11

I did.
One thing I just tested is that manually adding the number for the page size and scale does work now. So that is a huge relief, I can continue my work now.


#12

run as admin*


#13

You might try checking to see if there’s an update for the printer drivers.

Also, did you shut the computer down entirely and do a cold reboot?

FWIW, if you need to do this sort of scale printing more than once in a blue moon and your time has any value at all, you would be better off using LayOut for this kind of printing. It’s easier to set up and you’ll get better quality printed matter than you can get by printing directly from SketchUp.


#14

Did do a cold reboot. Didn’t work.
Yeah, once I’m finished with my studies and have a job and money I’ll definitly make the switch to pro :stuck_out_tongue:
Will maybe check on those another time, for now I’m satisfied and probably won’t need to use it again very soon.
Anyway, thanks for your help, always nice to have supportive people like you around.


#15

Hi, I’m having exactly the same problem as Baksteen. I’ve tried all the above recommendations without any success at all; I can enter values into the page size and scale fields but they have no effect at all. Are there any other suggestions at all, apart from moving up to Pro? My printer is an HP All-in-one connected wirelessly, a brand new installation. If the problem were drivers, it should work with the “print to pdf” or “XPS document writer” but it doesn’t. Very puzzling…


#16

Can you share the SKP file?


#17

Hi Dave. I would be happy to but it’s apparently too big to upload. Is that the only way? Or should I create another smaller file and try that?


#18

You can upload the model to the 3D Warehouse or to Dropbox and share the link. If you don’t want to make it public, send the link to me by private message.

You could try setting up to print with a different file. It may or may not be different.

When you installed SketchUp, did you right click on the installer and use Run as administrator from the context menu?


#19

OK. I’ll try it to the 3D Warehouse and let you know. Thanks so much for helping out…


#20

Hi Dave. I uploaded to 3D Warehouse - I checked it as a private model in case that’s relevant although I don’t really care. It’s called “westview”. Do you need more than that to access it?