Argh...printing misbehaving (or worse) both 2018 and Layout

Hi all, been snooping for a while but first post. I’d say I’m a novice but have been using for years for woodworking projects. Recently upgraded to 2018 Pro on windows 10 on a rather powerful PC.

I’ve watched a couple of Dave Richards Youtube videos on printing to scale but can’t replicate anything. When I open the Print Preview dialog box the Page size and Scale fields are empty and the drop down boxes for dimensions are grayed out.

Per Dave’s videos, I’ve tried to send to Layout. There both the Sketchup Model and Scaling Trays everything is grayed out.

I’ve run repair on both Sketchup and Layout.

Out of ideas. Sure could use some suggestions!

Thanks much, Bill

Are you setting parallel projection before trying to print or send to LayOut? Printing to scale is meaningless in perspective projection.

1 Like

Hi Steve, its been a while.

Yup, set to parallel projection. David Richards has a terrific Fine Woodworking video called “Printing From SketchUp” that I followed. In Sketchup I couldn’t get the scale or page size fields to accept entries and in Layout couldn’t I make the tray fields work.

I’ve also updated my print drivers just in case.

In the file menu go to “print setup” I think it’s the first one down the list and see if your correct printer is selected in there. If the correct printer is already selected then select a different option then reselect the correct one.

I don’t know if that is actually the problem but unless I select the correct printer in there (not print preview) I get the same thing.

It’s worth a try.

At this point, everything is worth a try! Unfortunately, no change

When you upgraded did you install SketchUp correctly by right-clicking the installer and choosing run as administrator? That’s also a shot in the dark, but doing it wrong can cause strange issues.

I sure think I did it right but who knows? I don’t recall seeing an option to run as an administrator. Also didn’t see anything about administrator when I ran repair. Thanks for following up.

Could you share a screenshot of what you’re seeing?

Hi, Thank you for taking a look at my problem. I’ve stripped the model of everything except the profile I’m trying to print. Attached is a screen shot of Sketchup with the print window open. Note that the everything in the screen size section is empty. I can populate the white fields but they have no effect. The gray dropped down fields where is should show the unit of dimension can not be used.

In the Layout screen I have the “Sketchup Model” and “scaled Drawing” tray open but none of the fields are available. This is the first time I’ve tried using Layout.

Thanks again, Bill

Are you absolutely sure you are in parallel projection? Since all content in the model is planar and perpendicular to the camera direction you wont see any difference, but it affects SketchUp’s ability to print top scale. You can also try clicking ‘Current View’ (should already be selected but worth a try).

In LayOut you have to select the viewport to enable the inspectors in the tray. The LO UI is very different from the SKetchUp UI, and all inspectors have a relation to the selection, while the corresponding functionality is encapsulated to Entity Info in SketchUp.

Another shot in the dark: are you assuming that choosing the “top” view implicitly also selects parallel projection? It does not! SketchUp’s views just mean that the camera is looking in a particular direction, independent of the projection.

1 Like

Thanks Julia and Steve. Yes, I’m sure I’m in parallel projection. (or more precisely I’m sure parallel projection is checked in the camera tab.)

Attached are two more screen shots from layout. The first screen shot has the tray open with viewpoint. It gives me access to the Sketchup tray but nothing in Scaling. When I put in “full size” it does seem to give me the scale I’m looking for. Unfortunately, I can’t get it to print anything but the center of the image. The second screen shot shows the print preview screen. The “page” field in the upper corner in inoperative and the icons to the left of close seem to have no effect. Thanks, Bill.

Hi @billreed0129, I have read your thread w interest. Please upload your SketchUp 2018 file to this thread, and I will take a look at in both SketchUp and LayOut. Best.

Thanks Lindsey, Here it is…carriage printing trial.skp (3.4 MB)

Hi @billreed0129, Thanks for sending over the file, makes the detective work much easier.

  1. In SketchUp 2018, File > Print Preview (Note one must Disable “Fit to Page” in Print Size area and enable Model Extents) to allow user changes to Page Size and Scale attributes. I also see in your screen shot above, that you need to select a Tabbed Scene Print Range, mine is Current View). See two attachments:

  1. My practice with LayOut is to: First, setup desired Scenes in SketchUp and Save (which you have already done). Second, open LayOut and select a paper size from Getting Started dialog box (I chose Letter Landscape div4). Third, insert SketchUp file (I chose to use menu selection File > Insert > [Select desired file name from Open dialog box],

  2. Note the blue outline around the Viewport. This indicates the Viewport is selected (and on a Layer that is “not shared across pages,” “burgundy outline is for shared across pages”), which makes the SketchUp Model Tray active (also, the Scaled Drawing Tray is now inactive or greyed out, this is to be expected as scaled drawing is a different functionality of LO). Now you can select the desired Scene. For Viewport “Scale” there is a dropdown box just to the right of the “Ortho” button (light shade of blue). This is where you select the Scale of a viewport.

  1. Lastly, when you click outside the Viewport, the SketchUp Model Tray becomes inactive and the Scaled Drawing Tray becomes potentially active (by selecting “Make Scaled Drawing”) which is for drafting in LayOut and not to be confused “to Scale” the SketchUp Model Scene Viewport.

Let us know if you have success (or any problems) to this point.

PS. following in @DaveR s footsteps, please update your profile for everyone’s benefit (license type, SketchUp version, Operating System)

Thanks so much Lindsey for taking a look at this. Very helpful.

Still got a problem but it’s narrowed down. The problem appears to have something to do with my HP printer or the Google wifi connection to the printer. See the two images below. The first is the problem I’ve been encountering. Notice the Page Size and the Scale fields are unavailable with my HP Laser Jet specified. If I change the printer to something called “Microsoft XPS Document Writer” lo and behold, Page Size and Scale fields are available similiar to the screen shot Lindsey sent using his Epson.

So, problem narrowed. I’ve reinstalled the printer drivers. I guess next I’ll try a direct printer connection and see it that works. Any other ideas?

Thanks all, Bill

If you export a scaled PDF, can you print that to scale from your PDF viewer? If not this would confirm an issue with the printer or its drivers.

opps, with the promised screen shots…

have you selected ‘Print borderless’ or equivalent in you printer settings?


Thanks all for your help and suggestions. Your thoughts along with DaveR’s finewoodworking video and lots of trial and error got me there. I think that my laser jet printer is not communicating through the google wifi to Sketchup when I initially go to print preview. Anyway, the solution was to always set the printer to Microsoft XPS Document Writer and always hitting OK out of the screen and then going back in to make scale changes. (If I don’t OK then the scale fields still are not available. You’ve got to exit first and the go back to print preveiw a second time.) From there export to PDF (2d graphic in Pro) and print directly to my HP laserjet. Same routine worked on Layout.

Very straight forward! :slight_smile:

Thanks all and it was a pleasure meeting you through this forum. Bill