My whole model disappeared/the screen is blank...?

I was working on a building model and clicked on the sample person in the middle to delete it and I must’ve misclicked because the person was then in a box and when I tried deleting it, I was only deleting clothes off of it. I didn’t know how to get out of this, so I tried deleting all of the clothes off of it hoping it would eventually all delete. I must’ve misclicked again because my entire model disappeared, and I cannot seem to navigate at all. The tools are clickable but I cannot affect the blank space at all. I see no axis either. I then tried clicking Edit > Undo maybe 10 times and nothing changed. I really don’t want to start over… Can somebody please help me get this back?

Clothes? :thinking: Could you upload your here, so we could have a look?

Wunderdome.skp (419.1 KB)

Hope that works for you.

I don’t suppose you were making components of the things you drew, were you? Have a look in the In Model components window and see what you see.

My In Mdoel Components Window juts says I have “Lisanne” as my only component. I don’t really know what I was doing at the time… I guess all I know is that I was editing “Lisanne” the figure since she was in a dotted-line box and I was removing things from her person… I got trigger happy because I figured I could just delete everything on her to make her dissapear but it turns out EVERYTHING disappeared. :frowning:

Oh no, not this issue again. I’m linking this topic to this one and this one. Also, I managed to (more or less) recover your file. Here you go.

Wunderdome Recovered.skp (1.6 MB)

Seems you were trigger happy to get her undressed. You should never do that!

Read about the basics of SketchUp and how groups and components work.

1 Like

Wow. THANK YOU SO MUCH. You saved my life.

1 Like

She was looking good, what can I say??

Happily your model was fixed. I’ve seen some cases where everything in the model space disappeared entirely but the components were still in the In Model library. The models were reconstructed by bringing the components out into the model space. Only groups and loose geometry had to be recreated. Unfortunately, if you don’t use components and this happens, you’re SOL.

I am new to SketchUp and I guess its a bigger monster than I expected. I’m just going to have to be careful until I actually know what I am doing. :joy:

Indeed!

At least be diligent about keeping entities close to the origin. Use Zoom Extents periodically to check for strays and round them up.

I’m sorry I am such a novice at this program… But this recovered file I cannot seem to edit. What am I failing to do?

Actually scratch that, I can edit it, its just the cursor tool is about 2 inches up and 4 inches to the right of where my actual cursor is… What is this from?

Ummm… Graphic card or OpenGL issues perhaps? Check your OpenGL settings for a start from Preferences > OpenGL.

That is very odd! Could you post a screenshot of that happening? @VahePogossian has a possible idea, but I haven’t heard before of it causing that symptom.

The original problem was like others we’ve seen in that the camera had somehow jumped to outer space, but this time there was no outrageously remote entity to have made that happen. I’d have loved to be peeking over your shoulder to witness what caused this! There is clearly a tender spot in SketchUp that causes it to blow up if you touch it!

1 Like

You can’t see my cursor in the screenshot but this is me making a line and my cursor is way to the left and down.

I’m still baffled, but perhaps the camera is still not healthy. Try this alternative recovery file and see if you fare better.

Wunderdome.skp (494.8 KB)

In this one, the cursor is still off only by a couple inches but in the same direction.

Baffling the Sketch Up community with my fuck ups… this would only happen to me…

Just for S&G, quit SketchUp and restart your computer. Then open SketchUp with a new blank file and see if the cursor behaves. Then try this model again.