Sketchup Model Vanished

Hi Everyone,

My entire model just disappeared… Im kinda new to sketchup but I tried to have everything in layers and groups (not sure if my layers were done correctly tho…). Everything was working just fine until I started importing files from 3D Warehouse – I should have opened them in a separate file and check them first but didn’t… I can still see all the layers and the file is not empty: 27,5 MB,
I checked the statistics:

Component Def. 302
Layers: 26
Materials: 196
Text: 0

but still cant see anything… I read all I could about some of the bugs and other peoples reports on similar issues but my sketchup proficiency is nowhere near enough for that.

The model is of a simple timber frame building which im actually getting ready to build but doing the whole thing all over again would suck…

Any help would be greatly appreciated…

Instead of posting pictures and such ill just share a dropbox link of the actual file

Thank you

Your model scene doesn’t seem to have anything in it. The components are still in the components tray.

Look in the same folder for a file named Timber Frame Workshop.skb, or one named AutoSave_Timber Frame Workshop.skp. Also look in your documents folder.

If you find the .skb file, change its name to something that is different, and change the file extension from .skb to .skp. Open that to see if it’s a better version.

If you find the AutoSave_ file, open that one. It is likely to be empty too, but worth a try.

Thanks for the reply…

Ive already tried renaming the .skb file to no avail…(didnt try renaming it to .skp though - just TimberFrameWorkshop2 - but since it didnt seem to work i deleted it) Its the exact same empty scene. I have a dedicated folder for all my sketchup files so its easy enough to check. As for the AutoSave_ file, I havent found anything like that, not even in my documents folder.

Can you see if the renamed .skb is still in your recycle bin? If it is, move it out from there and change the file extension to .skp.

Checked as soon i read your reply, even though i usually empty my RB frequently… Unfortunately its gone… Any other way to salvage the situation?

Next thing you could try is going to This PC level with File Explorer, and search for AutoSave_

That will find any auto save files no matter where they are. It takes a while to do the search. I sent mine searching a while ago, and it’s found 8 files so far.

There are ways to recover files from an emptied recycle bin, but I’m not expert on that.

Colin, i was just thinking the same thing… I can run a file recovery software ( have a few) but it takes (quite) a while and it uses quite a bit of the machines resources… If you think the lost .skb file would do the trick i could run it… Running the PC Auto Save search now

My search finished. It found 25 flies, though many of those are duplicates.

Make sure you typed AutoSave_ and not Auto Save.

Found it… Unfortunately we have this:Capture

Are you able to zoom into the origin on this model?

1 Like

Outliner showed no contents. I also ran an extension that fixes the problem of not zooming in, and it found nothing to fix. And I made a rectangle, did a zoom extents, and it nicely centered my rectangle.

I’m pretty sure there is nothing in the scene.

1 Like

I think I have stumbled onto a clue for this one.I had a model open that had 400 plus components and over 100 tags. When I saved it, I had the Components and the Outliner trays pinned, I then closed SketchUp. Later I opened SketchUp to a blank template, the two trays were open and the components tray was populated with the contents of the last saved model. The Outliner tray was blank as was model space. I can duplicate the situation. If I save the model with the trays collapsed and exit SketchUp the blank will open correctly.

What is the difference between pinned and open?

I can’t answer that one, my trays are individual that retract to the margin when not in use.

I will set up the default tray and try it out.
With the tray open and floating Components stays populated with the previous models data. If I close and open a second time the data is still present.