Sketchup Model is Gone...SKB file remains


#1

I was working in my sketchup model, I saved and closed my model, and came back to it about thirty minutes later. Everything is gone, down to layer zero, like I hit select all (including my dozens of layers) and deleted it, then saved and exited the model. I have no idea what happened. I don’t have a backup for my last 15-20 hours of work or so. I cannot recover anything from the skp file, it is totally blank.

However, the skb file is still there, and the picture preview shows my latest save of the model. Is there anything I can do to use that to save this model? Currently my computer tells me I am unable to open this file. I’m using sketchup pro 2016 on a PC running windows 10 OS.


#2

Edit: I was able to open the SKB file, and resave it as an SKP file…does anyone have any input on all of this? I’m a university student who is mostly self teaching myself sketchup for an architecture class.


#3

Sketch up files with an SKB extension are backup files (on Windows). You get a new one every time you save the original.

As you have probably worked out already, you can rename it to SKP extension, then open it.

Hope that helps understand what you’ve done.

Have you set the program to Auto save every X minutes? You should.


#4

Deleting stuff is not a way to save stuff. Often when things seem to have disappeared, actually the camera had zoomed out to some far away location. Camera > Zoom Extents (do Edit > Delete Guides if you have gobs of guidelines first) restores your viewport.

If you were still stuck, attach a file for someone here to examine.


#5

Catamountain,

I read a lot of other posts where this was a problem and I tried the steps suggested there, but that didn’t help. When I reopened my file, everything was gone as if I had deleted it all before I saved it - which I did not do. Even right down to the layers, of which only layer 0 remained.

However, I was able to use my SKB file to rebot the project and continue on. I’m just curious as to what the genesis of the problem was.


#6

We would have needed to examine the model before you did the select all and delete.


#7

Just to clarify this @catamountain , @basonnentag said ‘Like’ I hit select all and delete. You seem to be reading as if he said he did select all and delete.


#8

I would bet that your system has an Intel integrated graphics card…(it would be helpful to know your system configuration, btw…PLEASE PROVIDE THAT INFO IN YOUR PROFILE so that other users can better assist you. If you can’t identify your graphics card, ask in this thread and someone can probably help you get to the bottom of it.).

Issues with the Intel integrated graphics adapter have been well documented on this forum, and several users have reported SketchUp files vanishing from their systems.

The unofficial workaround was to uninstall the 64-bit version of SU2016 and replace it with the 32-bit version. This seems to have prevented the problem from recurring.


#9

Was there anything in the file left from your project? Camera location, scenes, materials, components or is the file identical to the template you have used? What happened to the file size?


#10

Regarding providing system information in the profile I think it’s better to include it directly in the discussion when it’s relevant. Providing it in the profile can be good too but you easily forget to update the profile each time SketchUp updates (my profile said I had version 6 - 2014 installed) or when you get a new computer. If you frequently use SketchUp on more than one computer (e.g. at home and at work) the profile information does’t tell on which computer a specific problem occurred.


Filling in Profile Information
#11

Point well taken, but I mentioned this in my response to the OP because his (her) profile identified the Graphics Card as “???”