Mouse issues

Hi, have used SketchUp 13 for many years,( which I still have ) but thought I try the 23 free version to see what it is like .
The issue that I’m having ( which I did not have on the 13 version ) is that very often , when I "orbit " , it actually goes into "pan’ and after a couple of tries , it goes back to "orbit " , also the zoom works to fast , I checked the mouse setting , with no success.
A few months ago , I installed the free Pro 23 and did not have any problems , so , I’m at a loss and truly I’m weary about signing up for a yearly subscription is this issue is not resolved .
Any help would be much appreciated , Thank you .

Do you mean sketchup 2013?

So you’re having issues on the website version, you don’t need to subscribe to be able to use that version, it’s free.

The free version runs in a web browser. It is likely that the issues you are seeing are due to browser limitations or incompatibilities. Have you tried a different browser to see if it has the same problems? My experience has been that Chrome is the most stable.

My apologies , the Pro23 trial version is downloaded on to my desktop , and it is , 2014 MAKE not 2013 .
Again , sorry for that

Hmm, often, when it comes to mice problems, it comes down to the mouse you use.

what is it exactly ? There might be a software to change its parameters.

Have you tried a different mouse?
My newest mice have lasted longer, but when I started using SketchUp I used cheap wired mice at the rough pace of 1 mouse/year. What broke first was always the scroll wheel button.

There also have been reported problems with mice that have a scroll wheel with side click functionallity…

Hello everyone and thanks for the responses , I have a Logitech $25 corded 3 button mouse and yes, I have tried a Logitech wireless one , but the wireless does not respond as well as the corded one , and like I said before , I do not encounter the issue when working on the 2014 version…

Thats still not enough information to do some investigation… Instead of the price which is of no use to us, give us a model name or number…

That doesn’t tell us if the other mouse has the same issues…

Do or did? And does the other mouse behave the same (as the other mouse) in both versions??

Ok, sorry ,

  • Corded Logitech # M100 works great on 2014 , issues in 2023
  • Wireless Logitech # M510 works great on 2014 , issues in 2023 .
    Does this help ?

I have used M510 mice for years. I currently have three of them in operation and have seen no issues at all with any of them in SketchUp for web, SketchUp Pro, or SketchUp for iPad.

Again , thanks for the help.
How about this new issue , when I try to " HIDE " measurements , the numbers hide but the measurement lines, arrows and a dotted box around the number , remains .

In fact , picking any item in the drawing , does the same thing ( 2023 version ), good on 2014.

Go to the View menu and untick Hidden Geomtery and/or Hidden Objects.

DaveR , thanks very much for that , it worked

So ,any suggestions to what can I do about the other problems , its very ,very frustrating , never experienced anything like that .
Could it be the software , maybe because I’m in a trial …not sure what to do

I doubt it’s SketchUp. And certainly not because it’s the trial version. As I said, I’m using the same mouse you are in SketchUp Pro and Go with no trouble at all. I’ve used the same model for years and have worn out a couple of them.It works perfectly for me. Do you have Logitech’s drivers installed?

Might be your eleven year old graphics card that makes it look like the mouse is the problem. When is the last time you updated the graphics drivers.

1 Like

I strongly recommend that you go to the Nvidia website and download and install the latest available driver for your graphics card. Based on your screenshot, you are running a rather high-resolution monitor so at least for larger models, you should perhaps try to optimize graphics performance by, for instance, turning off Profiles in your modelling style, and limiting the use of large texture images. Also check the available settings in the Preferences>Graphics dialog
First check in the Graphics Card details window that SketchUp is using your Nvidia card. If necessary, correct using the Nvidia Control Panel 3D Application settings.
As to other settings, I would choose moderate to no antialiasing and perhaps uncheck the “maximum texture size” box. For Nvidia cards, Fast feedback should be turned on.
Note that for every change in the Graphics dialog, SketchUp has to be restarted for them to take effect.

Hi , to Dave R thanks for the response , I update the drivers as they become available , also , my Logitech drivers are up to date and also my video card, also , the settings that you show under " preferences " are the same as you show .
I do however , take offence to the fact that I may have not the funds to buy a fancy video card as you perhaps can .
Thanks for the help