Model not working in web viewer

I am working on a truck-camper 3D model and since a few days, the web embedded viewer does not work… sometimes there was an error but now it just show a wheel turning for ever and nothing happens. I can download the model into a new project and it works fine… The model is called Bucher Mowag Duro 6x6… Can you please check?
The web viewer is at the bottom of this page: Paul Godard - Soul Photography

How large is the SketchUp model file? Are you using SketchUp Free as your profile indicates?

Edit: I see in the 3D Warehouse it’s 26 Mb.

I wonder if moving it close to the origin would change things. You’ve got it more than 92 meters away right now.

How do I do that?

I am using pro

I presume you mean moving the model to the origin. Select it all and move it.

Please correct your forum profile. It says you are using SketchUp Free (web).

I changed the origin but it does not seem to help…

One of the difficulties with forums and the internet is we can’t easily look over your shoulder and say, ‘oh, you know what you are doing but you are making a simple error’ or ‘oh my god revoke all computer privileges’.
Dave suggested you select everything and move it to the origin
but you said
I changed the origin and it didn’t seem to help.

They are not the same things.

1 Like

Sorry my mistake saying that… I selected the model and moved it to the origin… as he suggested.

I still need some help… please. I did “exactly” what was suggested eventhough I mis-communicated but it still not working… now it gives an error… “The specified model could not be loaded.” although everything is fine when I view the file with the viewer or if I download the model into a new file.

Your link is broken.

I pulled it out and it does download…

What do you mean “my link is broken”.

The link in the iframe?

It is as I got it from Sketchup… unless I am missing something that you can explain, so I can fix it.

If I copy the embedded link in my previous reply, it works. If I go to my website it does not work (error : The specified model could not be loaded.) but if I view the iframe in a new window (same as in previous reply) it works.

I don’t understand… especially that the same 3Dmodel was working inside my page a while ago.

@TheGuz may know if there have been recent changes that could affect whether iframe will still work.

I also asked the web team to check the page, because they look after the SketchUp web viewer code, and may be able to tell why it’s not working.

Thank you @colin
FYI, it works with the direct link in Mac Firefox but not in Safari unless you log in with a free account (which should not be necessary for the viewer.

Just confirming that it is broken (in Explorer). It looks like you tried fixing the embed link - that seemed like the right thing to do.

None of your errors stuck out to me, so no other thoughts on that…

The issue is whether you are signed in at the time. If you are signed in then the link should work, if you’re not signed in then the error shows.

It’s connected to a recent change where the number of downloads you do is counted. The embed model method doesn’t cope with the new way of tracking downloads.

I’ve asked the team how the embed instructions are supposed to work for cases where the user is not signed in.

Paul I see the issue you’re describing.
Would you be willing to update the embedded code? Not sure if that will fix it, but it’s for SCIENCE!

I have updated the model with the new embed code from warehouse… same error on FF Mac.
More info. A friend tried on Windows Firefox & Edge… same issue.

Ok… that’s something to think about. I used the embed code in the above post and it embedded nicely in the forum here.

We were able to reproduce the issue internally. we have a fix. We need to release the fix to production. I will update later on the timing.