New 3D Warehouse model viewer is broken!

3dwarehouse
viewer
bug

#1

Broken in all web browsers that I’m using. Chrome based browsers flashes an error for a split fraction of a second before switching to the old legacy model viewer while Firefox based browsers couldn’t load the model at all. On Microsoft based browsers, they don’t work outright, even the previous model viewer. Now I have to download the model everytime I want to view them.


#2

In Chrome

Hmmmm…


#3

On my end, it’s not working.

Says my browser supports WebGL, but when I use the viewer, it flashes an error and switches to the really old model viewer from the late 2000s. Amy I missing something? Is my ■■■■■■■ computer unsupported? They didn’t say anything about this stupid bull----!


#4

UPDATE: Managed to get it working. Seems that the new model viewer requires WebGL 2.0.
UPDATE 2: Seems that the only web browser that I can get WebGL 2.0 to work is Firefox with WebGL 2.0 enabled in “about:config” (It’s experimental, so be careful with it.)


#5

Yes, last night, we turned on the ability to render embedded models from 3dwarehouse now using the my.sketchup.com engine. This means the requirements will be the same. See http://help.sketchup.com/en/article/3000316 which states: We recommend using Chrome, Firefox, or Safari, and our regular test suite includes Chrome 42+, Firefox 35+, and Safari 8+. We’re working to improve performance in Internet Explorer 11 and Edge but can’t confidently recommend these browsers.

You can also discuss this here as well as http://forums.sketchup.com/c/my-sketchup. WebGL has been around for about 5 years and was based on OpenGL ES 2.0, so it’s not THAT experimental anymore. It DOES NOT require WebGL 2.0. Your profile says you have an AMD graphics card - what’s the model number?


#6

It’s not a graphics card, it’s a graphics chip embedded onto the motherboard. I’m using an AMD A8-5500 APU.


#7

Ah, so do you update via AMD Catalyst Driver? On Win 10, I think the OS updates it - I don’t know about WIn 8.1.


#8

I did, and still not working.


#9

I have all the requirements needed to use my.sketchup, but all I get is an error. I bet you saying “F U” to people with weak PCs and only give it to people that have 1GB video cards and expensive gaming PCs.


#10

My.sketchup works fine in my cheapo Chromebook. Tone down that attitude. There are people here who were trying to help you…


#11

Just in case, here’s the specs for my computer. There has to be something that is causing My Sketchup not to work in my computer without enabling WebGL 2.0 on Firefox.


#12

That’s a bit harsh, @michael_okeefe91, and that’s from me, someone who people think can be harsh at times. We’ve run this on Chromebooks (as @catamountain says) , so that’s not the case. We’ll continue digging into this to understand why.


Whoops SketchUp has crashed no web page 3d view
Error: This specific model could not be loaded
#13

Folks, I’m getting the same error…

I get the Trimble icon and the red loading-bar, then this error message.

The “get.webgl.org” test shows that my computer/browser supports WebGL, on my WinXP SP3, DELL Precision M90, and Firefox 47.0.1

Turning off my “hosts” file (renaming) doesn’t help.

-Taff


#14

For me, it says “Sorry, Sketchup appears to have graphics incompatibility with your browser”, although in Chrome that error flashes for a split second.

In Firefox, it doesn’t load the model.


#15

I’m getting the same error message as depicted in the screenshot included in the OP. I was just in the warehouse on 02 September. I had no trouble with the 3D WebGL viewer, but now this evening - this error message.

I have Firefox, Windows 7. I don’t use Internet Explorer, so I dunno if it’s the latest versions or not, but it’s version 11. Thing is, I have gone to IE on a couple of occasions whenever someone’s model wasn’t working to see if it was model or the browser (or something else), and discovered that the viewer doesn’t work right in IE anyway. I checked in IE tonite after things weren’t going well in Firefox, and IE still treats models the same crappy way it always has… so no answers there.

I went to the get.webgl.org after seeing that screenshot, and the page indicates that my browser supports WebGL also - the cube was spinning.


#16

BTW, all of the WebGL demos from…

https://www.khronos.org/webgl/wiki/Demo_Repository

…work fine, at respectible framerates. I only have problems with getting 3DWarehouse/mySketchUp to load & run.

-Taff
DELL Precision M90
nVIDIA Quadro FX 1500M
Win XP, sp3
Firefox 47.0.1


#17

@Barry
So I guess no one has come up with anything on this issue? Or has a fix or solution been posted somewhere else? Or has it just been forgotten because only a handful of us are unable to use the WebGL viewer in the warehouse?


#18

We have issues queued up, which we’re fixing. Nothing to report yet.


#19

OK, we’ve pushed a change to deal with our top 3 crashes, can you try your models? @taffgoch?


#20

No joy, Barry,…

…I get the same error message. All that has changed is that the loading progress bar no longer displays.

-Taff