Can't Access 3D Warehouse models with Firefox Browser


#1

Using Firefox version 51.0.1 (32-bit), on a Windows 10, 64-bit PC. 3D Warehouse page loads OK. Click on any model and it comes up OK. When I click on the “View in 3D Web GL Viewer” option it starts to load and then I get the error message “Error The specified model could not be loaded OK”. This happens with all models. Using Google Chrome and Microsoft Edge on the same computer, the models load with no problem (apart from a red warning with Edge that the 3D Warehouse has not been configured for use with Edge, but it seems to work fine). Any ideas how this can be sorted?


#2

it sounds like a Firefox problem if it works in other browsers. Have you checked to see if there’s any updates for Firefox? You might do a search on WebGL and Firefox to see if others have had issues and resolved them.


#3

It works fine for me - screenshot from Firefox 51.0.1 64bit Win10


#4

Type control-L and then type in http://www.geeks3d.com/webgl/ and see if that renders and what capabilities are.


#5

Many thanks Barry. The link worked fine and came up with the following diagnostics:
WebGL Capabilities

experimental-webgl context: NO
drawing buffer size: 600 x 600
VERSION: WebGL 1.0
VENDOR: Mozilla
RENDERER: Mozilla
SHADING_LANGUAGE_VERSION: WebGL GLSL ES 1.0
Platform: Win32
App version: 5.0 (Windows)
AA enabled: true
AA samples: 4
MAX_VIEWPORT_DIMS: 32767x32767
MAX_TEXTURE_SIZE: 16384
MAX_CUBE_MAP_TEXTURE_SIZE: 16384
MAX_RENDERBUFFER_SIZE: 16384
MAX_VERTEX_TEXTURE_IMAGE_UNITS: 16
MAX_TEXTURE_IMAGE_UNITS: 16
MAX_COMBINED_TEXTURE_IMAGE_UNITS: 32
MAX_VERTEX_ATTRIBS: 16
MAX_VERTEX_UNIFORM_VECTORS: 4096
MAX_FRAGMENT_UNIFORM_VECTORS: 1024
MAX_VARYING_VECTORS: 30
WebGL extensions: 23
    1 - ANGLE_instanced_arrays
    2 - EXT_blend_minmax
    3 - EXT_color_buffer_half_float
    4 - EXT_frag_depth
    5 - EXT_shader_texture_lod
    6 - EXT_texture_filter_anisotropic
    7 - EXT_disjoint_timer_query
    8 - OES_element_index_uint
    9 - OES_standard_derivatives
    10 - OES_texture_float
    11 - OES_texture_float_linear
    12 - OES_texture_half_float
    13 - OES_texture_half_float_linear
    14 - OES_vertex_array_object
    15 - WEBGL_color_buffer_float
    16 - WEBGL_compressed_texture_etc1
    17 - WEBGL_compressed_texture_s3tc
    18 - WEBGL_depth_texture
    19 - WEBGL_draw_buffers
    20 - WEBGL_lose_context
    21 - MOZ_WEBGL_lose_context
    22 - MOZ_WEBGL_compressed_texture_s3tc
    23 - MOZ_WEBGL_depth_texture

I am not a techie so would appreciate some guidance as to if this shows light on the problem I am having?


#6

Many thanks Tig. Can access that site OK, but models won’t render in 3D. Must be a Firefox setting so have raised it with their help Forum - see if they come up with a solution.


#7

BTW, any particular reason you’re using 32-bit browser on a 64-bit system?

I’m on Sierra with FF 51.0.1 and having issues. A coworker with the same browser isn’t. We’re looking. Please submit crash reports - when I acknowledged the crash, I got a crash reporter and submitted.


#8

I am used to using Firefox and there currently isn’t a 64-bit version although there is one in beta.

I will submit crash reports.


#9

I also run FirefoxNightly, which is 53… Firefox 51 runs like c-r-a-p for me, hogs CPU, kicks on fan… 53 is much better on Mac.


#10

The 64bit Firefox for Windows is well hidden…


Be aware that [like most modern browsers] it no longer supports Java Plugins directly.

I’ve had no issue with v51 on Win10…


#11

OK, for some reason unknown, the problem has vanished and all is working as it should. Many thanks to everyone who has given advice.


#12

I realize the OP has marked this issue as “solved,” but I noticed, upon returning to this forum looking for new info as to why I can no longer view models with the WebGL viewer in the 3DWH, the OP was experiencing the same issue as I am still experiencing - Error The specified model could not be loaded.

@Barry - I went to http://www.geeks3d.com/webgl/ as you had the OP do, and as with other pages that test whether one’s browser supports WebGL, the graphic worked perfectly fine. The diagnostic returned was exactly the same as the OP’s with one difference: the diagnostic is one line short. The variation comes in at line 7 where the OP’s diagnostic shows, “7 - EXT_disjoint_timer_query.” My diagnostic does not have this info, and instead for line 7, picks up where line 8 on the OPs diagnstic continues. Dunno if this will explain anything or not, or help anyone in determining why I STILL cannot view models in the 3D viewer. This diagnostic was done in Firefox 50.1.0/32-bit, I did not run it in FF51.0.1/64-bit.

Of course the reason I am now on this thread - I STILL cannot load ANY model in the WebGL viewer in the 3DWH. I was using Firefox 44.x.x when this all started in September 2016. I have upgraded several times hoping that upgrades will solve the problem, and am now on Firefox 50.1.0 - which I am now sorry that I have, and I am continually getting prompts to upgrade yet again which to this point, I have refused to do. But after someone in this thread asked why the OP was using a 32-bit browser on a 64-bit machine, I decided to look into that. I too was running a 32-bit version of FF.

As mentioned before, I have a Windows 7 laptop. Chrome does NOT play well on this computer. IE, as everyone knows (unless something has changed in the past few months) is WORTHLESS in the 3DWH.

So now…I’ve downloaded and installed FF Nightly again - now v54, and this time, 64-bit. That was a big disappointment, as on the 3DWH index page, if I try to scroll thru the feature categories, any featured model that was off-screen before scrolling comes up a blank box. I clicked one to see what it was. The page containing the model loaded just fine and displayed the model. But when I clicked on the “view in the WebGL 3D viewer,” I ended up staring at a crash report - which I promptly submitted. So much for FFNv54/64-bit. Uninstalled.

After a reboot, I installed FF51.0.1/64-bit, despite the fact that I did not want yet another newer version of FF, AND the 64-bit comes with reduced plug-ins capabilities. I suspect that might have been the issue with Firefox Nightly above. Turns out, I experienced the same thing with this version of FF as I did with FFNightly - if I try to scroll thru the feature categories in the 3DWH index page, any box that was off-screen before scrolling comes up blank. I clicked one to see what it was. The page containing the model loaded just fine and displayed the model. But when I clicked on the “view in the WebGL 3D viewer,” I ended up staring at yet another crash report - which I promptly submitted. Then uninstalled this version of FF also.

Also, @Barry, yes, I did try to load some “models with different memory allotments,” none of which worked as I indicated in my email reply. As for submitting crash reports, I’m going to assume that they are automatic whether the process notifies me of one being generated or not. It was very rare that I was ever presented with one, and in fact had never seen one until well into discussion on this issue in the thread New 3D Warehouse model viewer is broken! Tonite, while I was presented with a crash report in FFN54 and FF51, I was not presented with one when I tried to view models in the WebGL viewer in FF50 before and after downloading, installing and trying in FFN54 and FF51.


#13

As the originator of this thread I thought the problem had gone away which is why I originally marked it as solved. However, the problem has not been solved as when I next tried to view a 3D model in Firefox it would not load and gave the same error message “Error The specified model could not be loaded OK” At that point I gave up in despair. As of today it still doesn’t work.


#14

Well, I have given up on this. All I want to do is to embed 3D [B]Sketchup[/B] models into my website to give users a good overall view of what I am making, and at first sight [B]3D Warehouse[/B] looked the ideal medium. However I have had no joy using [B]Firefox[/B] to access the models in 3D which is possibly linked to non-standard web compliance with the [B]3DWarehouse[/B] Website. I also very much dislike the inane messages displayed as a model is loading.

I have now returned to my original solution which uses an abandoned software application called [B]Spread3D Free[/B] (V1.4), to convert a [B]Sketchup[/B] model into a [B]Flash[/B] animation which I can then upload to my website and ensure web standard compliance (This seems to work fine with all browsers I have tested including [B]Firefox[/B]). You can see an example of what this looks like using [URL=http://www.pettigrews.org.uk/odg/pic-html/phase-08.htm][B]THIS[/B][/URL] link to my website. Note that [B]Spread3D Free[/B] is no longer supported but still works OK with version 8 of [B]Sketchup[/B] (the current version of [B]Sketchup[/B] allows one to save models in version 8, so problem solved!). However, I will keep monitoring the [B]3D Warehouse[/B] site to see if the problem with [B]Firefox[/B] and web standards compliance are eventually resolved.


#15

That will happen as FF updates itself automatically. My current FF now behaves for CPU usage, but really sucks with YouTube. Again, if you have problems, give me OS, browser & version, graphics card and model ID from the 3dwarehouse (link to model), and we’ll test it. Developers are very responsive to this, but it’s always a moving-and-for-the-most-part advancing target.


#16

@Barry – “That will happen as FF updates itself automatically.” – Firefox will update automatically if that’s how one sets FF to run. I do not allow FF to update automatically so it’s not a case of Trimble necessarily trying to keep up with Mozilla - I would never have lost the ability to view models in the WebGL 3D Viewer to begin with, as my environment had not changed when I lost the ability to view models using the WebGL 3D viewer. I have FF set to notifiy me of newer versions. I decide when and if I want to update. I am currently running the next to the latest version of FF, but the ONLY reason is because I was hoping I would be able to again enjoy viewing peoples’ models in the WebGL 3D viewer in the warehouse.

Last time I got anything to load in the WebGL 3D viewer was 26 or 27 Sept 2016, so it seems that something was being worked on. I couldn’t load every model I tried - 5 of 15 loaded, but it was heartening to see that some did. After that day, I never got another model to load again.

Again, if you have problems, give me OS, browser & version, graphics card and model ID from the 3dwarehouse (link to model), and we’ll test it. Developers are very responsive to this…” – I thought that’s what they were doing in another thread (that seemed to just die) that was supposed to have been addressing this issue. How many models do we have to post to be tested before the developers understand that for those of us who are no longer able to view models in the 3DWH thru the WebGL 3D viewer, it is not just some models on which we get the error, it is nearly all, if not all of them.

@DaveR – As far as FF being the problem, last I read, FF is one of only three browsers that is supported. Chrome lugs my system down, and when I looked into Safari, Safari is no longer supported for Windows-based systems

Today, I decided to check the 3DWH in Internet Explorer again on the outside chance that something has changed. I chose a couple models from the “Recent Models” row on the index page –
https://3dwarehouse.sketchup.com/ model.html?id=33d8ca0c-be07-4508-8f75-0420221bf8f0
https://3dwarehouse.sketchup.com/ model.html?id=84f9f52a-4f70-4cd0-8344-ec248b2385a4
All I got was a message that read, “Oops! The 3D view is not available for this model. Check back soon. Our render bots are working on it.”

From the “Staff Pick Models” row (older models) –
https://3dwarehouse.sketchup.com/ model.html?id=c657eee20d6ebdef32baaa45ea97959c
https://3dwarehouse.sketchup.com/ model.html?id=u4ba46ea8-b9e0-4e4e-97a0-e89b36551e17
All I could do was spin them, and zoom in and out without control as to perspective

Just for giggles, I tried the above four models in FF-50.1.0 (I’m still on Win7, BTW) –
And as has been the case over various versions of FF & FFNightly (32- and 64-bit) since September 2016, I got the now familiar, “Error. The specified model could not be loaded”

Are those who use the “pro” versions of SU having this issue? Just curious.

Like @tim7 I too had pretty much given up on the warehouse as anything I would like to see now, I HAVE to download it. Period. But I wandered here to this board once more a few days ago, in hopes that some solution had been found since last I looked, and just happened to trip over this new thread.


#17

If I have crashed Firefox previously, I can make current Mac FF 52.0 fail on those four models.
If I restart Firefox, I can successfully load those four models. If you crash, please try restarting and see if it helps. I will ask if we could alert on crash and ask the user to restart the browser to retry loading models.

If you browse those inside SketchUp 2017, you’re loading them with Chromium, not Firefox, and you should try that as well.