Manual dimensions issue with Mac OS and SketchUp 2017

#1

I started up a new SketchUp project after not using the program for about a month and a half. I cannot enter manual dimensions any more.

For example, I start with a new project, add a rectangle, hit the Tab key to manually enter the dimensions of the rectangle. For one thing, the Dimensions input is not highlighted as it used to be after hitting the Tab key.

But more importantly, if I were to enter “12 1/2’” when hitting the spacebar between “12” and “1/2” the Measurements input goes blank and the rectangle is no longer selected. This behavior with entering spaces while typing out dimensions seems to be the big issue. Any time I hit the spacebar, the Measurements input goes blank and I cannot continue entering anything.

Same behavior if I attempt to enter a measurement while doing a scale operation.

This is SketchUp version 17.2.2554 and Mac OS Sierra version 10.12.5

Thank you if you can share any insight into why this is happening.

0 Likes

#2

Actually I found the answer in this thread: Spacebar doesn't complete command and return to arrow

Mac System Preferences > Keyboard > Shortcuts > Keyboard

Setting the “Change the way the Tab moves focus” option to “Text boxes and lists only” fixes the issue.

I’ll leave this in case anyone comes here with this issue.

0 Likes

#3

You do not need to hit the tab key at all (you also must not click the measurements box) to enter dimensions. Just click to set the start corner, move the mouse to tell SketchUp the general orientation of the rectangle, then let go of the mouse and type the value(s) followed by return.

0 Likes

#4

Such a simple thing, but I wasn’t aware of it, and it’s great to know!

However, there are still issues entering manual dimensions. After setting the Tab focus back to the default, the issue I was having with the spacebar seems ok without using the Tab key. But I then found an issue with the Shift key. For example if I scale an object, let go of the mouse and start manually entering some distance in inches, e.g. 12", when the Shift key is pressed to type in the " character, the input goes blank.

There may be workarounds, like typing “in” in place of " but basically after changing the Tab focus setting to “Text boxes and lists only” the UI simply goes back to behaving the way I expected it to. Just documenting what I experienced in case it’s helpful to anyone else.

0 Likes

#5

If your units are inches, you also don’t need to type the " to designate inches, just type the number. The interference by the shift key is due to a System Preference setting (sorry, can’t remember which right now, hopefully someone who can will chime in…).

0 Likes

#6

The mac system preferences fix I know is the one the op described earlier which switches shortcuts to text boxes and lists only. I had the old “spacebar switches to geolocation blues” once and fixed it this way. I don’t believe the shift key can be assigned as a stand alone shortcut in Sketchup or Mac OS, only as a modifier, so shift cannot be triggering another tool or system shortcut on its own. Sometimes non standard keyboards (UK) or foreign language keyboards trip up the system, I assume you’re not working with either of these?

EDIT: unless shift " happens to be assigned to something?

0 Likes

#7

It is due to your ‘smart quote’ settings in the Mac. Disabling will fix.
Mac->Sytem Preferences->Keyboard

1 Like

#8

Hi there, I’m a new user to sketch and I’m following the tutorials to the letter… however I feel like I’m having a similar issue described above, but the solves suggested don’t seem to work - any new thoughts on this would be hugely helpful…

For getting exact dimensions for rectangles, I click once, then drag. I then type the dimensions I want - e.g. 16’,8’ and hit return… then nothing. I’m running on Mac OS Sierra and Sketch2017 and can see the dimensions entering into the input field on the bottom right… but return doesn’t snap the rectangle into place. ANybody have anything similar - it really does feel like a mac keyboard issue, but the settings edits above aren’t helping.

0 Likes

#9

What do you use as a decimal separator?

Try typing 16’;8’.

Also make sure you are not clicking in the Measurements box before typing the dimension.

1 Like

#10

thank you!

With your help, the solve I’ve now found is to use ; as the separator rather than , (in spite of the fact that the official sketchup tutorials on youtube clearly say use , as the separator). What’s more, if I finish the command with . then it doesn’t work either. Thanks again for your help - can’t believe such a simple thing had me bugged for so long…

0 Likes

#11

The instructions are written for those who use a period as a decimal separator. Due to your localization, you use a comma as a decimal separator so the comma can’t be used as the separator between two different dimensions. That would create confusion. That’s why you need to use the semi-colon.

2 Likes

closed #12

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.

0 Likes