Sketchup Web - Mac OS > Dimensions box clears when I use the spacebar or enter anything other than numbers

I have been using Sketchup Web for over a year via my apple mac using the Chrome browser.

The issue is when drawing a rectangle and specifying the dimensions the dimensions box clears when I use the spacebar (or any non numerical value).

Example: I want to draw a rectangle 9920 mmx 5000 (mm)

  1. Select rectangle tool
  2. I want to enter the dimensions 9920 mm, 5000 mm (this has always been accepted in the past)
  3. I can type the 9920 but as soon as I use the spacebar it clears and the box goes from “Dimensions” and renames to “Measurements”

This is driving me up the wall and I have used this hundreds of times! It’s the same deal on Safari so I wonder what it could be.

Any help would be greatly accepted.

Others have posted about the same issue recently. I can’t remember what was said but I would expect the devs to be working on it by now.

Yes the space bar is currently a known issue that is being addressed, but it shouldn’t actually be a problem for you, you don’t need to use space with metric input.

Start drawing your rectangle, drop the mouse and type 9920mm,5000mm and hit return.

I take that back, the mm is causing issues. If you are working in mm you can just type 9200,5000 and it should work. Or if the model units are meters type it as 9.2,5

Someone else worked around ‘m’ by using ‘M’.

I tried that and it didn’t work, I made be doing something different. You could set the units to millimetres and then not type mm at all.

Actually, it seems to be more than just the spacebar. The evidence suggests that the code that parses your input for measurements is breaking and interpreting anything non-numeric as a shortcut key instead of units.

Thank you. I do hope so as I’m going back to pen and paper with a scaled ruler :grinning: Old school but can’t be broken by software releases!

Thanks everyone for your support I thought I was going mad.

I can confirm that by specifying the dimension without the “mm” or a space e.g. 9000,5000 I can now size the rectangle correctly.

This is based on the template set to mm/m.

Thanks all

This problem has been fixed, and should now work for you in the live site.

1 Like