Can't enter dimension symbol

I’m a SketchUp Web user on a Mac and I’m unable to enter dimension symbol for inches (") because Shift key activates constrained mode and resets the dimension! Safari or Chrome, same problem.

This is not the default behavior.
You can reset the shortcut by click on the magnifying glass a middle of left side of screen and start typin short then click to the command.

image

Note this will reset all your shortcut to defaults. But easy to recreate.

In scenarios where Shift activates the constraint causing the tool to pick a new point, this can lead to the text you are already writing being overridden.

In my setup (Windows, desktop SketchUp, Swedish keyboard) I experience this when typing ; in the rectangle tool, but only the current rectangle is very close to being a square or a golden ratio. When the rectangle has another ratio, Shift does not cause the text I’m writing to disappear.

In what tool(s) and what situations are you experiencing this issue? What keyboard layout are you using?

FWIW, if you are using the Feet and Inches template you don’t need to enter the " for inches. They are understood.

1 Like

Thanks, but none of this helps. I’ve been using SketchUp for Windows for years on personal homeowner projects, but now I have a Mac and because of the insane pricing structure I’m reduced to using the PoS web product.

To draw a simple 16’ line, I enter 16’ then press Enter and it draws a line 16 inches long. Trying to enter it any other way generates an invalid input error. If I try to use the " symbol, when I hit the Shift key my previous entry is overwritten by the cursor position.

I hate this interface but I should be able to enter simple dimensions without this much hassle.

1 Like

I’m struggling to reproduce this. For me typing 16" works as expected, on both mac and Windows.

Would it be possible to record a video of what you are seeing?

That’s not what I see. If I type 16’ and press Enter I get a line 16 feet long. If I type 16 or 16" I get a line 16 inches long.

Thanks everybody. Problem solved. I’ve been using the US-PC/International keyboard layout for years on both PC and Mac but on the Mac I must use the standard/default US layout. D’oh!

Really appreciate the effort, it encouraged me to keep trying,

I wondered if you had your Mac set to create curly [aka smart] quotes - you need to turn that off if so (in Settings/Keyboard somewhere).

“smart”, not “curly”! System Preferences->Keyboard->Text has the checkbox to enable/disable smart quotes.

1 Like