Problem with measurements input

I am having a little problem and wonder if you could help me with it.

The fact is that I have always used the metric system but now I must use feet and inches for a model I am doing. The problem is that the measurements box will not accept the feet and inches symbols.

I imagine that to draw a line that is 10 feet 7 inches long, I should enter 10’ 7” there. But it will not take the symbols and the length comes out wrong. It is even worse if I need to enter something like 6” 4 3/4”.

Is there a way to fix it? I tried with two keyboards, changed machines and even changed number format settings. Nothing worked.

Thanks in advance. And, ah, I’m on Mac OS Ventura.

Don’t put in a space between the 10’ and the 7".

Ok. But the problem is that the symbols for feet and inches do not show in the input box whereas they work fine elsewhere in the Sketchup file.

What language is your computer set up for?

Please see the attached files.

The key capture think doesn’t seem to show pressing Shift and the apostrophe.

I noticed that too. But the apostrophe works in callouts. Very odd.

Very odd indeed.

I’m not a Mac user but read somewhere about the “Smart quotes” or “Use smart quotes” in System setting of Mac OS, try to find this setting and turn then off.

1 Like

Thanks but it did not work.

There’s a faint bell ringing in the back of my mind that there was a problem with some combination of SketchUp and macOS versions in which the shift key was being preempted as a modifier for tools and hence it was impossible to use it to get either kind of quote mark from they keyboard. Alas, it’s buried too far back for me to remember what was the workaround and I think it was fixed in later versions. Perhaps @colin remembers?

I found this in the 2023 release notes:

  • Using the Shift key with the Scale tool on an AZERTY keyboard now works as intended.

I think there was also an issue where trying to type shift-1 key, to get ‘1’ on a French keyboard, had problems. That may have only been in the web version, because I couldn’t see it in the desktop release notes.

@edson why is it you are using SketchUp 2022?