Can't use ' or " modifiers to indicate feet and inches


#1

Hey everyone! I am pretty new to SketchUp, although I tinkered with it many years ago when it was still a free Google product. I come from a construction background, and am based in the US, so working in a “feet, inches, fractional inches” format is just how my brain functions. In the web based version, as well as the trial version of pro, when I start drawing a rectangle the dimension box shows the format in “feet, inches” like I want. As soon as I start typing numbers to change the dimensions it will only allow me to enter them as “inches”. So if I want a rectangle that is 10’,10’ I have to enter that as 120,120. Am I doing something wrong? This problem persists with the push/pull tool, and everything else I’ve tried. I would love to be able to enter my dimensions as 21’6",8’6" etc. as this would save me a lot of time versus converting everything into straight inches. I am designing a tiny house on wheels, as well as a school bus conversion, for context.
Dan


#2

In both versions you can change the Units to feet and inches.
In the desktop version it can be found at Window/Model info/Units.
In the web version, on the right side bottom Icon is model info and units are in there.


#3

Box,
Thanks for the quick reply! I have the units set under “Model Info” to Format:1/2" and Precision:1/16". And it displays correctly as I start the action. As soon as I try to type anything in to set the dimensions I want, it will only allow inches to be entered, and no fractions. This persists in both Chrome and Safari. I am running MacOS High Sierra if that makes a difference.
Dan


#4

Not sure what to tell you, with the same settings it works for me in Firefox. May well be a Mac issue, but I’m a win man.


#5

if you are seeing an error in both the web based Free version and the pro trial installed on your machine…the error is caused by something you are doing. (unless it’s a mac thing)
I can enter 9’ 12 and get a ten foot edge.


#6

Thanks, I am able to enter fractional inches after all, but not feet, inches. Perhaps I’ll try Firefox just for grins.
Dan


#7

There have been posts about some sort of keyboard setting in mac that tend to override default settings. Don’t know anything about it and can’t remember what the setting was called, but it might give you a hint.


#8

Thanks for the reply. The problem for me is that when I type the ’ to indicate feet, nothing shows up in the dimension box. Same for the " to indicate inches.
Dan


#9

If it doesn’t show up in the input box it is not entered. When there is no specified unit SketchUp uses the model unit, which explains why you get it in inches.

What happens if you try to write 1m or 1mm?


#11

Sounds to me as if smart quotes might be enabled. There’s an OS setting somewhere that turns them off, but I’m not a Mac person, so I don’t recall where they are.


#12

I work in construction too and metric is how my brain functions, but we’ll probably never get rid of imperial here as we still have old doors in feet and inches that need replaced.

In SketchUp Free, I am able to type dimensions in any of these formats:
3’6
3’6"
2’3 7\8
2’3 7\8"
and they both work in Chrome whether smart quotes are on or off. Safari doesn’t like the " part so it’s better to leave that out, but 3’6 still works. Leaving it out saves typing time anyway.

None of these problems are affected by smart quotes being on or off. If you want to try it for yourself, you’ll find the setting in System Preferences / Keyboard / Text / untick “Use smart quotes and dashes”, but it made no difference for me.

On Safari with smart quotes turned on or off, the " doesn’t work but you don’t have to use it, use the 3’6 format instead of 3’6". I think SketchUp Free works better in Chrome anyway, so use Chrome.

I’m also on High Sierra here, version 10.13.4 (17E199), Chrome Version 66.0.3359.139, Safari Version 11.1 (13605.1.33.1.2) so I don’t know why it’s not working for you.

I can type archaic sizes like 2’3 3/4" in SketchUp Pro 2018 and it works fine, but not as nice as metric.


#13

If that is the case, on Mac go to System Preferences/Keyboard [Text] tab, and uncheck the Smart Quotes checkbox
image


#14

I’m experiencing the same issue as well. However, I’m finding that the apostrophe key is linked to the assignment of hot keys without assigning it to anything. I use the “right” key as a hot key and after assigning “zoom” to this, the apostrophe key will delete the value I type in. So long as the “right” key is assigned to “zoom” The value prompt will not function.

(I have smart quotes disabled btw)

Has anyone found a resolve yet??

Thanks!
J


#15

I’m not sure what you mean by the “right” key. Do you mean the right arrow key?


#16

Right arrow key

Played with this a little more. Some background: I use Left, Up, and Right arrow keys to orbit, pan, & zoom. When I assign a hot key (zoom) to the right arrow key, it appears to disable the apostrophe key (feet) When pressing the apostrophe key (after entering a value) it appears to be non-functional and zeros out the value entered. It’s impossible to enter a length for a line. Thanks for your help/time.


#17

Since they lock inferences I would never assign arrow keys as shortcuts, so I’ll have to test this when I get back to my computer.


#18

I figured out what is happening. Per the Instructor window, if I assign a shortcut to the right arrow key, the apostrophe key will mimic that assignment. In other words, they both adopt the same function; in this case “Zoom”.

Any idea how this can be fixed or resolved? Maybe it’s happening with other keys??

Thanks!
J


#19

One way to resolve it might be to not reassign the arrow key shortcut as it is a significant part of the inference engine. Zoom is already assigned to z and a scroll wheel will zoom for you.


#20

I could do that, but it doesn’t resolve the mimicry issue. I would also like to keep the workflow I’ve established over the last 10 years.


#21

There are several keys presses that are NOT suitable for Shortcuts - they are ‘reserved’.
These include the numerals 0…9, the comma/semicolon, [, ], <, >, the Shift/Ctrl/Alt/Esc/Enter keys, and the 4 Arrow keys etc - these are all linked to either dimension-input possibilities or drawing inference tools etc…
On a MAC other keys are hard-coded by the system - e.g. Cmd+C etc for Copy…

So by trying to force your personal preferences for a particular shortcut-key, which is already ‘reserved’, is therefore a recipe for disaster !

There should be no ‘mimicry’ if you avoid trying to shoehorn unsuitable keys into shortcuts…