Cannot enter dimensions on MacBook Pro


#1

Select rectangle tool. Mouse click on a location. Move the mouse to create rectangle outline.
Dimension box shows dimensions in feet and inches.

Attempt to type 12".
As soon as the shift key is pressed before " a dotted diagonal line is drawn in the rectangle and the dimension box changes to a new dimension with minus signs in front of each coordinates.

Attempt to type 12ft.
As soon as the f key is pressed the offset tool is selected and the dimension box changed to “Distance” and is blanked.

Attempt to enter 12’, 3".
Same behavior as soon as shift is pressed.

Attempt to enter 12’, 3in.
Same behavior as soon as i is pressed.

Same behavior with circle tool.

In system preferences there are no keyboard shortcuts.
Use smart quotes and dashes IS NOT checked.
Text boxes and lists only IS checked.

Reproducible on an (old) MacPro running El Capitan and a (new) iMac 27 running High Sierra.

Suggestions on what is hijacking the shift key or a letter key on these Macs?


#2

What units do you have selected in Model Info.

If you have Inches selected, " is understood. No need to type it.

To enter 12 feet type 12’. Not 12ft

No spaces. 12’,3 should do it.

in. is not correct. Look at the way the dimensions are displayed in the Measurements box and use the same format.

I don’t believe keyboard shortcuts for SketchUp Free are listed anywhere. some keyboard shortcuts are the same as in the Desktop version so you could look at the Quick Reference about halfway down this page.


#3

Thanks. Feet and inches.
The ft and in were a suggestion by someone else. Just tossed them in.

So
12 is 12 inches
12’ is 12 feet
12’4 is 12 feet and 4 inches
12’,5 is 12 feet, 5 inches
12’,5’ is 12 feet, 5 feet
12’,5’4 is 12 feet, 5 feet and 4 inches
12’6.5’4 is 12 feet and 6 inches, 5 feet and 4 inches.

Never type anything for inches. Always type ’ for feet.

And so goes the first day.

(The last example should be 12’6,5’4 as was pointed out by a responder.)


#4

There you go.

And don’t click in the Measurements box. If it’s available for input, just let go of the mouse and type.

Tiny correction: It should be 12’6,5’4. Comma, not period. I expect you meant a comma but for someone coming along later…

You could also type 12.5’ for for twelve and a half feet.

The only time you need spaces is for fractions. 12’4 3/8,5’7 1/16 for example.


#5

Yes, I know not to click in the measurements box.

Yes, about the dot/comma. Thanks.

OK on the space for fractions.

I just tried this on a Windows box in another office and the " works fine on that box. Probably Windows 7 and Chrome.

So this avoidance of " is Mac-specific or Safari-specific? Any idea what the underlying cause is? I have seen other examples where folks were using the " inside feet/inch dimensions. Using Safari here, of course

Just tried 4,5’3in on that Windows box and it appeared to work. Other examples with in and " seem to work. ft does not seem to work. I thought I had seen in inside other examples.

I had not noticed any docs that explain this in detail and had been mislead by other examples I had seen. Makes enough sense to go forward.

Thanks.


#6

It might be a Safari thing. I just tested it on my old MacBook Pro on Safari and see the same issue when hitting Shift. Shift is a modifier key for many of the tools, too. I never use Safari so I hadn’t noticed this with SketchUp Free before.

As I said, if you are using Fractional inches or Architectural units, the inches are understood but on Chrome and most other browsers you can type " if you feel like doing more typing.


#7

Thanks again for the quick and focused responses, and for the loosened perspective on what appear to me to be inconsistencies. My physics background makes it difficult to not enter all the units!


#8

Not sure if it applies in this instance (and I can’t test because I’m not on a Mac!), but on this forum I’ve seen a few instances of Mac specific measurement entry difficulty that were ultimately found to be caused by the operating system’s “Smart Quotes” setting - it should be turned OFF.


#9

No. It doesn’t. As the OP indicated in his first post, Smart Quotes are disabled.


#10

From his original post!


#11

Yup, I knew about that one. The original message indicates that it was NOT checked in my case.


#12

Whoops! Missed that detail. Oh Twell.


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.