Typing units in dimension box triggers tools instead

bug

#1

Hello everyone.

I am using sketchup pro 2017 17.2.2554 on macOS Sierra 10.12.3

I used to be able to type units in the Dimension Box after the values. Instead it now triggers tools.

Sample procedure detailed:

typing R triggers rectangle tool.
Click once to set first vertex,
Drag
Would like to type 10m;20m to draw a 10x20m rectangle. But now, as soon as I hit the ‘m’ key (after the number 10), it triggers the move command. Typing cm for centimeters would trigger the circle command on typing the ‘c’ in cm.

Behavior is reproducible with different tools (line, tape,…)
It behaves as though SU wasn’t aware of the context of dimension input.
SU behaved normally yesterday. The only difference applied to my machine since then was an Xcode update.

I am really confused. Any help would be very much appreciated.


#2

I just fired up my Mac and tested it. No problems for me. If I type R before typing the radius, the tool changes to the Rectangle tool but if I type the R after the radius value, it works as expected. All the others work as expected, too. You aren’t clicking in the Measurements box before you start to type, are you?


#3

Thanks for your answer. I am not. As I said, I have been using sketchup for quite a long time, and it is the first time I encounter this problem.


#4

Just reinstalled SU. Problem still here. Crazy…


#5

Sketchup works as it should on my windows machine.


#6

Check you Accessibility set up for the MAC Keyboard…
Some sort of Sticky or Slow key weirdness ?


#7

Thanks TIG. Nice tip. I progressed a bit:

I plugged an external usb keyboard and sketchup behaves normally on typing on this keyboard.
I proceeded to examine the keyboard settings on the mac, deactivated auto-correction, for example. Nothing else seems abnormal. But still cannot obtain normal functioning with the laptop keyboard. (Of course I checked that the input source is correct -French- in my case).
This is so strange.
When typing ‘m’ for meter after a dimension, it triggers the move command.
When typing ‘cm’ for centimeter after a dimension, it triggers the circle command.
So the proper character is sent. But it behaves as though it would send an extra character (space) that exits the current command (rectangle, or line for example) before sending the ‘m’ or ‘c’ character then triggering the corresponding command.
And why a difference between the usb keyboard and the native keyboard ?


#8

Do you have some other auto-correct app set up, so when you type in 123m it adds the space -
making it 123 m
When it does that the ‘m’ is then divorced from the number, so that SketchUp sees it as a ‘m’ key-press and not part of the length.
What happens if you type 123m into a plain text document is a space added when using the flaky keyboard ?
Why it does it in the one keyboard and not the other is plain weird !


Perhaps some ‘measurement’ setting needs un-checking so 123m is OK
Perhaps the laptop keyboard has some of its own settings that need adjusting, as the global ones seem to work otherwise ??