Bug when I add units in the value field on mac

bug

#1

Hello,

On mac with SU 2014 (osx maverik) then SU 2015 (osx yosemite) and now 2016 (osx el capitan) I encounter a bug when I add units in the value field.
I had no problem with SU8

SU 2016 is a fresh install, no plugin yet. I also disconnected all the pre-installed extensions. Always the same.

I reported the problem here. He disappeared a short time, but it is still there :

Occasionally I add values after unit. Like “8mm” rather than “0.008”

With the scale tool it is imperative to add the unit to define the precise distance between the two red handles.
example: “230mm” or “67cm”

On my mac no way.
as soon as I enter a letter SU call the keyboard shortcut tool !

Example :
when I draw a rectangle 50cm x 500cm. If SU is set to cm unit I simply types [50;500] in the Measurements Toolbar. No problem.
If I want to go faster I type [50;5m]. It worked well with SU8. But with SU2014 to SU2016, when I type “m” that called the move tool.
Type “cm” call the Circle tool and then the Move tool !!!

It is not very serious in these situations. It is more annoying with the
scale tool when you want to get an accurate value between 2 handle.
Currently impossible to me. It worked well with SU8

I changed the preferences mac keyboard language (French keyboard ,
french numeric keyboard, American english …) Nothing change.

Have you experienced the problem? Have you resolved?

I use a french keyboard with or without numeric option

I recently met a guy with the same problem on a older machine

Thank you for your feedback.
Erom


#2

So the question is: what have you changed in between?


#3

The problem appears with SU 2014. On a MacBook Pro 13 "2009. Then i decided to change my hard drive for an SSD. I did a clean install. When I restart work the problem was gone… for a few hours. It became quickly. And I do not know why.
Now I work on a macbook pro 13 "2014. And I’ve always had the problem on this machine.

The only solution I found is to change some shortcuts like C, M and S by others. So I can use these letters to indicate units in the VCB.


#4

OK, I redid the test. I set my keyboard in US. (Azerty to Qwerty) “M” is on the key “?”.

I draw a circle. I select.
I launch scale tool with the “s” key.
I run the scale tool between two handle by pressing "4?"
It works !!! many times

I return to the French keyboard setting.
I draw a circle. I select.
I launch scale tool with the “s” key
I run the scale tool between two handle by pressing “4M” It works… only once!
Then it stopped working :frowning: