Dimensions suffix for Scale tool not working on Mac OS Ventura in French

If I type mm, cm or m after a number it works.

If I use ’ for feet or " for inches, it doesn’t work.

Is this a bug ?

I would say so, as it works fine in English on Windows.

It may be the regional settings causing the issue. Like having to use ; instead of ,

Or “smart quotes”?

1 Like

Smart quotes are off on my Mac.

SU 2022 on my work PC (Windows) works correctly with the Scale Tool.

I have another problem on the PC but I prefer to start a new thread to avoid mixing things too much.

I tried setting my region to France, and my keyboard to AZERTY. With that I could scale to 10 inches with shift-&, Shift-à, " (the 3 key). I could scale to 10 feet with shift-&, Shift-à; ’ (the 4 key). Is my test valid?

What I find strange and illogical is that I can use the ’ for feet and the " for inches when specifying a length for an edge, a radius for a circle, a displacement value or whatever length I need to enter.

It is only when specifying a length with Scale Tool that it doesn’t work, As soon as I type the ’ or the " the VCB field get emptied and filled with only the ’ or the " and, of course, if I press the Return or the Enter key, I get an error.

I’m not near a computer to check, but is this related to how shift affects the scale tool. Perhaps you need to click to finish the scale before typing anything that needs shift.

I don’t use the Shift key. It is just a simple scale along only one direction.

I can use mm, cm and m as a suffix but not ’ and ".

ok, I tried, made a 1m cube, grab the tape mesurer, turn guidelines off, hopbidiboup, ask for 1" - it scales
then, undo, select the cube, take the scale tool, scale it down randomly and ask for 1" - it scales too.
then, same thing, but I type the 1" after randomly scaling, still works.

not sure where if fails on your side… I’m using the lastest ventura and SU releases. in french.

Fair enough, my mistake, I just know with a qwerty you need shift to type "

I got it to work using this workaround:

1 - Select object;

2 - Select the Scale tool;

3 - Scale using a pure number as a scale factor;

4 - Type a number followed by a unit suffix like ’ and " followed by a press of the Enter key.

Now, the suffix is appended to the number instead of clearing the VCB.

I still wonder why using mm, cm and m works and using ’ or " doesn’t when used immediately after scaling but before pressing the Enter key.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.