A Problem with Making Dimensions in Sketchup


#1

Hi!

So I am having some trouble with the dimensions on Sketchup.

I draw a rectangle, type in the dimensions, and click enter, right?
Every time I click enter, the rectangle disappears, and I am typing in the dimensions just like the video said.

Also, I have tried clicking to make the rectangle gray before I type in the dimensions, and it still deletes the rectangle.

Whenever I click enter the rectangle deletes itself.

HELP

I am using a Macbook Pro.


#2

How big is the rectangle you’re trying to draw? Perhaps the camera is zoomed back so far you can see it. Or the camera is zoomed in so close the edges of the rectangle aren’t within the frame. Try making the rectangle and then click Camera>Zoom Extents. Does the rectangle show up?


#3

It’s not there. I’ve tried everything, but it always deletes the rectangle when I try to enter the dimensions. Could there be something wrong in my settings maybe?


#4

Can you draw a line with the Line tool? Can you draw a rectangle without typing the dimensions? Is it possible you are clicking in the Measurements box before typing the dimension? If you are doing that, don’t. Just start the rectangle, let go of the mouse and type the dimensions in the format x,y.


#5

I can definitely draw with the line tool , and I can draw a rectangle by itself. I haven’t been clicking the dimensions window because I saw somewhere that you don’t need to do that. I am going to try this one more time.


#6

Check your PMs.


#7

what exactly are you typing?

john


#8

What is a PM?

I have been typing 10’,20’ just like it says in the video.


#9

PM= private message. Click on the D in the cyan circle in the top right of the screen.


#10

FWIW, this was solved by turning off Hardware Acceleration.


#11

hey guys. Sorry to bring this topic up but I need help
Im another newbie in sketchup and having this problem. the above mentioned solutions did not work for me. the problem is when I draw a rectangle this is the steps:

  1. pressing R on the keyboard
  2. click somewhere in the 3d space
  3. typing the dimensions for example 20,20
  4. hitting enter on the keyboard
  5. NOTHING HAPPENS

the rectangle is still at the size of the mouse drag and is not created yet.

I tried it almost with anything (comma, semicolon, Tilda, star, minus, plus, even white space) but nothing works.

when I type something like 20' or 20 it works and creates a rectangle that has 20’ or 20" in one of its dimensions but the separators does not work at all.

my system decimal character is . (dot) and character grouping character is , (comma)

why is that?
my Version is Sketchup pro 2017


#12

hello, for me (in france) the seperator is “;”

To make sure of it, just start drawing the rectangle with the tool moving the mouse around, the right separator will be shown in the dimension box, simply reuse it !


#13

It might be just an oversight in your post, but after the click did you move the mouse a bit before typing the dimensions? The tool isn’t ready for input until you do so because it doesn’t know which plane or orientation to use.


#14

My God You’re a life savior. the separator was there and for some reason, it was something in another language because I can’t find such a character on my keyboard. it was an upside down semicolon (؛).

For other people coming here for the same problem, the character is called List separator character in windows 10 -> control panel -> region -> formats tab -> additional settings -> change the list separator character to semicolon or any other character and click ok and again click ok

Dude, the problem was that character was different from regular semicolon so i was seeing that in the dimension box but thought it was a semicolon. I changed it as mentioned above and its now good to go.


#15

Glad you got that sorted! For the benefit of others who might read this, what locale and keyboard settings is your system using? Is that symbol conventional in your local language (being an ignorant American, I’ve never seen it before :smirk:)?