Unable to enter exact dimensions when creating a rectangle shape


#1

I have resisted using Sketchup for a while and decided today that I was going to learn it. I have a simple residential bar that I have designed on paper that I want to create in Sketchup using Sketchup Pro 18

  1. I launch the app and see the familiar grey-haired old man standing in my workspace.
  2. I select the rectangle tool from the draw menu popup and move my mouse to 0,0 on the workspace.
  3. Click and drag to roughly the area that I want while paying attention to the VCV (?) dimensions in the corner (apparently this establishes your intended plane)
  4. Before clicking, I enter the exact coordinates of my rectangle by typing 89" x 12" I see the dimensions in the VCV change, but alas the image on the screen remains the same.
  5. I press enter expecting to get my rectangle starting at coordinates 0,0 and ending at 89,12.
    NOTHING HAPPENS.
  6. I press return–nothing.
  7. I click and get a rectangle that is the size that it appears on the screen which is not 89" x 12"

Before I go into the 400 other ways that I try this, can someone please tell me if I am being unreasonable in my expectation that the previous series of actions should work the way I expected?

I am going to build my model in a reasonable program (something super over the top like Autocad or Cinema 4D–you know, something easy to learn because it follows common sense, established user interface protocols) and hope to be able to open it in Sketchup so I can save it for the next person to use it to create a pretty graphic. But seriously, what is going on with this app?

RANT:
I don’t know why the authors of Sketchup think that it is acceptable or appropriate to have “magic input” interfaces where you just magically type (without seeing an insertion point or an input field) and press enter to get your results. It is completely counter-intuitive. I spend my days training old people that they MUST click in the field to expect what they type to show up. If they just type without a field selected (much like you have to do in this program), you have no way of knowing where you are entering the information or if the information is actually being recorded. Literally, I have said this probably every day for months now. Why on earth would you violate this fundamental principle in UI? If you want to allow “mystical input features” that should be extra–something you choose by preference. It should not be the ONLY way to enter dimensions. And regardless, it should work.

Thanks in advance for your support, sorry for the rant.


#2

You’re entering the dimensions in the incorrect format. Use either a comma or a semicolon as the separator depending on what you use as a decimal separator. If you use a period for the decimal separator, use the comma. If you use a comma as the decimal separator, use the semicolon. Pay attention to the way the dimension is displayed in the VCB and use the same format. If you have inches selected as the units, you can skip typing the " because SketchUp will know that’s the units you are entering.


#3

That is hilarious. It worked and I appreciate your help. If they want you to enter it exactly like it shows up in the VCV, they should accept “x” because that’s how it’s displayed. Either that or display it with a comma the way it is expected.

This app needs a UI overhaul. Perhaps a version that uses established UI protocols would be nice and would increase sales and users.

Thanks again for your prompt reply.


#4

I won’t argue against your rant, this is indeed an idiosyncrasy of the SketchUp GUI that causes newbies to trip quite frequently. But it is clearly documented in the SketchUp tutorials and help, so getting confused by it comes down to RTFM (which we all know users never do :wink:).

An even worse quirk on the Mac version is that when you type return after entering a value in many fields, the focus remains on that field with your entry highlighted - which means that the next character you type replaces whatever you meant to enter! I have no end of layers and scenes named “l” or “m” or space accidentally.


#5

Show a screen shot of it showing the X. I see a comma.
Screenshot%20-%207_27_2018%20%2C%208_50_45%20AM

The X is used for creating arrays with Move/Copy and Rotate/Copy which makes it problematic to use as the dimension separator.


#6

By the way, how to type in dimensions is explained 40 seconds into the second getting started video.


#7

That’s odd…I always see it separated by a comma in the VCB, never an x.

edit BTW: as you can see in @DaveR’s screen shot, pressing shift to type the quote momentarily causes SketchUp to lock the plane of inference which creates a wider blue border.


#8

That’s precisely where I got the idea from in the first place. I wasn’t aware that the comma was the only or required separator allowed. It seems like a simple programming issue to accept the comma and the x…easier, in fact than the period because the period could be used in each dimension.

Thanks for your reply.


#9

No offense, but programming issues are rarely as simple as they seem :wink:


#10

They don’t show using x as the separator in the video.

Except you don’t use a period as a separator because it could be used in decimal dimensions.


#11

That’s true although in my screenshot, the rectangle shows that way because Shift+Print Screen is the shortcut for making a screenshot of a small region of the screen for my screenshot tool. :wink:


#12

As someone who in the past had suffered from tendonitis due to using a mouse 50+ hours a week, and has begun suffering recently from arthritis in the hands, … adding a extraneous mouse move (usually to the extreme corner of the display) along with a frivolous button click … into every darned tool usage would be unacceptable.

This “term” is beyond ridiculous !

There IS in GUI design the concept of autofocus. It is in fact a HTML 5 property that I’ve used several times this past few weeks designing web dialogs for SketchUp extensions.

I’ve been around … building and programming computers as long as you, and whilst generally true, …
there is no actual “GUI law” that states a programmer cannot provide an auto-focused control on an interface. If it is appropriate for the activity and expected by the user that a control be autofocused, then it should be implemented as such.

In the case of SketchUp’s VCB (aka Measurements) toolbar, the characters typed are displayed in the Dimensions input box as the user types.

The SketchUp programmers did not set out personally to make you out a liar with respect to your “focus law”.

They NEEDED to have the VCB autofocus because moving the mouse up or down changes the indicator to the tool’s logic of what plane or axis the geometry will be drawn upon using the input from the user.
Example: I myself have the VCB toolbar docked in the upper left, 1st toolbar on the 2nd row of the upper container. If I want to draw a rectangle upon the XY ground plane and IF it were necessary to click in the input box of the VCB, then the rectangle ends up being drawn upon one of the vertical planes. (I just tried it and it got drawn on the XZ plane.)

SIDENOTE: I have my VCB docked to the upper toolbar container, and I do not experience the “limbo mode” problems other users have when clicking the VCB inputbox (other than the geometry being drawn in some orientation between the first click the the upper left direction of where the VCB toolbar is docked.)


The main “truth” in this topic thread is that ALL the SketchUp controls do not follow the same visual indicator “rules” to show hover and focus. (And they should!)

The “semi-rule” SketchUp uses for “a lot” of it’s controls, is to make the border blue when the control has focus. As soon as the 1st point has been entered with the RectangleTool, the VCB (Value Control Box,) … begins (ie it is blank prior to this,) displaying a coordinate pair and the input control has a blue border (indicating it has received focus.)
But, this focus border is rather “weak” both in color and thickness compared to the hover style for the Classification toolbar. (I have the two toolbars side-by-side on the 2nd row of the top toolbar container.)

Now compare the hover and focus styling to various controls in the tray inspector panels or the Preferences and Model Info dialogs. The GUI does not have consistent visual behaviors in these respects.

Before you say this OS dependent, … realize that SketchUp is using a mix of native and custom controls. The controls could have more consistent behavior IMO.