Hitting 'Enter' is not working to create shapes with exact dimensions

shapes
dimensions

#1

I’m trying to make shapes with exact dimensions. I click a shape button, let’s say the square one, click onto the plane once and then type in for example 10’,20’. I see it inputting into the dimensions box (which I’m not touching I’m just typing on the keyboard) except when I hit ‘Enter’ nothing happens. In fact the initial in-progress shape I was making goes away completely. Any ideas?

Thank you!


#2

Are you dragging out the rectangle before starting to type the dimensions? Or are you just clicking once and beginning to type? If you aren’t dragging the rectangle out after the first click, SketchUp doesn’t know how to orient the rectangle. You need to give it that.


#3

Yes, dragging it out, see how the dimensions are going into the dimension box also, but when I hit enter nothing happens and actually that initial shape disappears


#4

Did this just start happening? Did it work earlier?

What if you just type 10,20 and hit Enter?

I sent you a PM.


#5

I’m brand new to sketchup so I don’t think it’s ever worked. Maybe it’s some kind of other computer setting that’s overriding the enter…I don’t know? I’m on a mac and I’m using a tablet but when I just use the keypad it doesn’t work either.


#6

Hmmm… Mac… Tablet?


#7

The 10,20 does the same thing. I just noticed although the shape disappears on enter the dimensions remain in the dimension box.


#8

A wacom tablet


#9

Can you open the Styles window, click on the little house icon to go to In Model and choose the Edit tab? Make screen shots of the Edges and Faces edit windows and share them.

Do you have a basic mouse that you could try this with?


#10

I don’t have a regular mouse unfortunately, but when I use my regular computer keypad and unplug the tablet it still does the same thing. Two screengrabs attached (it’s only letting me sent them one at a time in this thread)


#11


#12

OK. Nothing there.

Long shot. Have you shut down and restarted your computer? That’s a Windows tech support sort of thing but sometimes it works.


#13

This is a complete shot in the dark: have you changed the Active Layer in the layers window to one that is hidden? You should always leave Layer0 Active when drawing new geometry.


#14

Good thought! Except you can’t hide the active layer’s contents, right?


#15

Graphics Card ?


#16

What about directing the op to where the model entities are? Can’t think where it is myself right now.

Just to see if there is anything in the model?


#17

Look at Window->Model Info->Statistics


#18

How about other geometry ?
Like a Circle ??


#19

Oops! You are right. So much for wild stabs!


#20

I’m thinking the graphics card is the only thing left if restarting the computer doesn’t do it.