I can't make exact shape dimension in my SketchUp

dimensions
rectangle
measurements
vcb

#1

Hello, my sketchup pro 2015 is having some problem. I cannot make exact dimension for any kind of shapes. For example, I want to create a 1000mm200mm rectangle, the dimension can be entered but the final shape won’t be 1000mm200mm, it will be in other length.

I’ve tried to uninstall the program over and browsing for similar problem but nothing works.

Thanks!


#2

Are you typing the dimension as 1000mm*200mm? If so, you are entering the dimensions incorrectly. Uninstalling and reinstalling a program will never fix that kind of thing. Drag out a rectangle and look at the measurements box as you do. The character between the dimensions will either by a comma or a semicolon. Use the same when you type the dimensions. 1000mm,200mm or 1000mm;200mm.

If you have Units set to mm, you don’t need to type the units. Just type the numbers and the comma or semi colon.


#3

No I use comma 1000,200 to enter the dimension. No mm or else.
Any suggestion Dave?


#4

Are you clicking in the Measurements box before you enter the dimensions? If so, don’t. There is never a reason to click in the Measurements box. Just drag out the rectangle, let go of the mouse and start typing.


#5

Use the Rectangle tool.
Click the start corner.
Move the cursor out to form a rectangle approximating to what you want.
It’s a good idea to have the longer side in the same orientation - that way you’ll know whether to type in 1000,200 or 200,1000
Click to make the rectangle.
Release the mouse and immediately type 1000,200 and press the enter key.
Tthe rectangle should resize accordingly.
Never click on the Measurements Box - that is simply showing you what you have typed.
Provided that you do not click again or activate another tool you can continue to type in alternative values + enter and the rectangle will adjust to suit.
Only when you activate another tool does the rectangle’s size become ‘frozen’…


#6

I already did let go the mouse and it’s still the same. The rectangle size did not match the size I entered.


#7

OMG Dave I just tried the semicolon and it works. I always use comma back then. Thanks! Do you know how to change the semicolon settings back to comma?


#8

Semicolon works because for the language option you have, a comma is used as a decimal separator. You need an English (American English?) language setting on your computer.


#9

As Dave says, it depends on your Computer’s settings.
These default differently depending where in the world and so on.
If you use a full-stop [aka ‘a period’] as your decimal separator, then in SketchUp you use a comma as the ‘list’ separator:
e.g. 1.234,56.789
Typical in English speaking countries, and former parts of the GB Empire.
But if you use a comma as the decimal separator, then in SketchUp you must use a semi-colon as the ‘list’ separator:
e.g. 1,234;56,789
Typical in much of the EU, latin-countries and so on.


#10

Okay then, thankyou very much TIG!


#11

This topic was automatically closed after 91 days. New replies are no longer allowed.