Lost Default Window and Extensions Warehouse

My Default window is lost in the ether. I’m on Windows 11, using a second monitor for SU Pro 2023.

I have tried the alt spacebar trick to no avail.

I don’t have a plugins pulldown menu at all.
When I select Extensions > Extension Manager, nothing happens.

Suggestions?
I would try the repair SketchUp function, but I don’t know how to find the installer.

Most likely your windows are “lost” on the other monitor. Try unplugging the second monitor and see if the windows gather back. I had this happen to me using a MacBook with two external monitors.

Tried that and things got even worse.
Now I have a blank window stuck on my screen that won’t close.
It stays whether SU is open or not.


Well that’s fun.

I’m out of ideas. Maybe @colin has a suggestion for a fix?

First thing I would do it go into SketchUp’s Preferences>Workspace and Reset Workspace. Then quit SketchUp and do a cold reboot of the computer. Try again with the Extension Warehouse to see what happens.

BTW, we only sell FOP :crazy_face:

Hi Dave.
I have already reset workspace a couple of times.
I rebooted twice, the second time got rid of that blank window, but I still get nothing when I attempt to open the Extension Warehouse.

I have seen you recommend a repair by opening the installer, but I don’t know where the installer is or how to open it.
Thanks!
I’m bona fee dey.

You could download the latest version of the installer at sketchup.com/download/all Right click on it, choose Run as adminstrator, and then choose Repair. Give that a try.

I bet you’re the Paterfamilias.

I can report the same. Just tried using SU '23 and opening Extension Warehouse. No go. I went there via a web browser and then a magical process occurred somewhere in the nether regions of the abyss and now the Extension Warehouse extension works.

Extension Warehouse and some other windows, are really web browsers. The things they download are cached, and it may be that cache has problems.

In File Explorer, paste in this path:

%AppData%\SketchUp\SketchUp 2023

Delete any folders in there that have WebCache in the name, and reopen SketchUp.

1 Like

Thanks Colin.
I tried that, but am unable to make the computer do it. [Sketchup is not open or running at the time.]
When I click on extension manager or warehouse, nothing happens.
See my screenshot.

I did as you directed and ran the repair.
No change.
Still doesn’t work.
No extension manager, warehouse, and no default tray.

You should close SketchUp first. But, that gave me a new idea…

After SketchUp is closed, open task manager (you can do that with Ctrl-Shift-Esc). Make sure More Details is selected, and scroll a long way down the list. Look for any entries that are named sketchup_webhelper.exe, and End Task those.

image

1 Like

As I said before, Sketchup was closed.
I opened Task Manager and found five sketchup_webhelper.exe entries.

Attempted to delete each, but two of them are persistent. I tried deleting them, but they won’t go away.

I opened Sketchup, and I still have no default tray, and no extension warehouse or manager.

Go to Processes and right click on the sketchup_webhelper.exe enteries and choose End Task.

That’s what I did before.
When I relaunched Task Manager they’re all gone now.

SU still broken however.

Next thing that’s a bit more drastic: Go into User/AppData/Local/SketchUp/SketchUp 2022 and delete the PrivatePreferences.json file. Then open SketchUp again.

1 Like

Now I see what you mean.
Task Manager showed SU being open in that screen shot, even after I closed it. I don’t undertand that, because I closed it, and I’m running two monitors, and the SU monitor was blank.
Perhaps it was open somewhere else.
It’s definitely off now, and Task manager shows it off now.

I don’t know how to get into: User/AppData/Local/SketchUp/SketchUp 2022

AppData is normally a hidden directory. In File Explorer you can set it to show hidden folders. I’m on my phone at the moment and disremember the exact steps but a quick search on the Goog will give you instructions before I can get back to my desk.

Search, “show hidden files in file explorer”.

EDIT:

The path is something like:

C:\Users\username\AppData\Local\SketchUp\SketchUp 2022

Probably, for you:

C:\Users\George Bock\AppData\Local\SketchUp\SketchUp 2022

Did you try signing into the Extension Warehouse from a browser?