Locking Toolbar Pallettes

I am sure I am not the only person requesting this, and probably not the first who experiences this “irritating” issue. Picture it: you set up your UI with all the toolbar pallettes you need around your workspace. Everything lines up all nice and neat. You exit out of SU and go back in and low and behold, your toolbar pallettes aren’t sitting right. They may be shifted out of place, causing the rest of the toolbar pallettes to either disappear or just plain misalign.

Could there be a way, a feature perhaps in SU, where you can lock the toolbar pallettes so they don’t shift positions? Maybe in the options tab (when you right-click in the blank area of the toolbars) there can be an option to lock their position.

Just a suggestion.

1 Like

This shouldn’t happen, normally. Exiting SketchUp should automatically save the positions etc.
Do you have multiple instances running?

@DaveR funny you should state that I shouldn’t have this problem if I installed SU correctly. I’ve been using SU for 4 years now and have ALWAYS had this problem, no matter the version. I can’t figure what I would have been doing wrong for the past 4 years of installations, re-installations or otherwise. I’ve always had admin privileges on my own computer as well, so again, I don’t know what else the problem could be. Is it possible my usage of Vray would be the culprit, since it loads its toolbars after Su has started up?

1 Like

I see this type of thing for users that have disabled windows UAC.
This causes issues for lots of software installing incorrectly and simultaneously opens your PC up to malware and other nefarious things.

I can imagine how irritating this would be. Could you post an image of how you are trying to organise your trays? For what its worth - I use Vray and haven’t experienced this problem.

Yes, I know about right-clicking to install as admin, and that’s how I have installed SU. Is that wrong?

Ok, nitpicking aside, YES I have installed SU by right-clicking and choosing “run as admin”. Any program I install on my computer, is done the same exact way. As far as a repair goes, what exactly is that going to do, that hadn’t already been done with the original install? Could these incremental updates from Trimble for SU, and using their automated update install be a culprit to? Should I be just installing the raw installers instead of doing updates?

The “resistance” I have is based solely on the fact that I have A LOT of plugins, add-ons, paths, directories, etc set for SU and it’s a risk that if something goes wrong, I lose a lot of time and money having to set everything back up again! I can’t tell you how many times I have to re-download plugins from the 3d warehouse, not to mention plugin reinstalls from Sketchucation and the licensing that goes with them. I am constantly on the clock nowadays and to even entertain a repair si not something I look forward to.

I still don’t get how permissions have anything to do with the installation? I am the sole user of SU on this computer, since it is my own personal computer, not a work computer from an employer. There is only one account on this computer and it’s mine. If there is a strict process for installing SU, I am all ears.

Well I took your “sage” advice and downloaded the installer available to me. I right-clicked on the installer and chose “run as administrator”, after a moment, the SU logo window came up on the screen with a green progress bar. After which, I got a message to close running applications…strangely it thinks SU is still open, but it isn’t. I kept trying to advance from that window, but kept getting the same message.

Yes, I have wasted too much time with this issue. Sarcastic comments not withstanding, I wasn’t trying to be difficult. As the tag attached to my post dealt with a feature request, I figured that was the only option to get my point across about the toolbar position not holding. I am of the belief that the way I have my toolbars set up on my computer, as well as having the vray toolbars open, causes SU to shove other toolbars out of the way, which is odd but considering I am dealing with two different apps working side by side, I should expect issues like this. Since I’ve dealt with it for so long, I should just keep my mouth shut and deal with it.

Open the taskbar manager, look for a process called ‘comsurrogate’ and stop it. This should run the installer again.

Usually, when something odd is going on, (anti) virus software spoils things.

Thanks Mike. Much appreciated and thoughtful.

I will post a more detailed response later with exactly is going on with the toolbars.

So i did as @DaveR suggested earlier, by performing a repair. The installer did what it needed to do, and after closing and a reboot, I restarted SU and experienced the same issue. As a test I conducted, I created two screenshots to display what my “default” layout of toolbars looks like and what happens after I close SU and re-open.

As you can see, on the left-hand side of the screen, the main toolbar will shift downward. THIS is the main issue I am having and thus, my request to create a way to lock the toolbars. Furthermore, I performed a test by removing the second row of toolbars in the upper portion of the window, so only a single row remained. I moved the left-hand toolbar back up to where it needs to be, closed SU and reopened. As I suspected, the left-hand toolbar did not shift downward.

The long and the short of it, when multiple rows of toolbars are placed in the upper portion of the window, the left-hand toolbars (I usually have more than just the default there), will all shift downward, due to the upper rows of toolbars present.

Again, this is something I’ve been dealing with for a very long time in SU, no matter the version or update of SU I had installed. i realize to some, this may be a very minimal issue and more of an aesthetic thing, but for me, I find it irritating, and possibly something that perhaps the SU team could look into, IF that is, this is an issue that more people other than me, have encountered.

If nothing comes of it, fine, I’ll move on, but since this post garnered some attention, I’d be interested to hear from others on this.

Frankly, that sounds like a bug in the way SketchUp is saving the toolbar locations. I think if they fix the bug your requested feature will cease to be needed.

1 Like

I can’t dispute that assessment that it’s a bug, and if need be, I can post this in the bug section, but since this has been historically, a long-standing “bug”, I won’t hold my breath that it will get fixed. If it’s not a bug, in that the toolbars float to allow adjustment of toolbar locations, the addition of more toolbars to each anchor area of the app window, then the requested feature to lock the toolbars may still be warranted.

Hi all, I have had the very same problem for the last 4 or 5 years!
I had the large tool on the left side of the screen with some more toolbars under it an another single row of toolbars left of that. On top I had 2 rows of toolbars. Every time I opened Sketchup the large toolset was in place until the rest of the toolbars loaded. Then it would jump down 1 icon like in @jjmorvay 's second screenshot. And ofcourse the rest of the double row too. But not the single row of icons left of the large toolset…
I never bothered to mention it here but I have tried many times to move it back, to see it move down again after a startup…
Sketchup make 2017 was installed correctly by running the installer as administrator.
Have done a few repairs (for another reason) but that didn’t help either.
Windows UAC is not disabled.
Two weeks ago I decided to do some housekeeping because Sketchup was lagging.
Cleaned up the SSD to create more diskspace and thought to do some spring-cleaning in Sketchup as well. Had read about extensions causing lagging so I disabled all extensions that I was bearly using. after that I reorganised the remaining toolbars.
Now have only 1 single row on top and only the large toolset on the left side.
The problem went away, never saw it happen again!
So I definetly think this is a bug of some sorts. Not a critical one, just annoying. :smirk:

It appears to be a bug in the Large tool set, which has always been a strange toolbar. Fixed at two tools across, only vertical and won’t let you put two tool bars side by side under it. Haven’t used it for many years. I’m guessing it is repositioning according to its invisible titlebar.
For someone who likes his toolbars just so I’m surprised you haven’t made a custom one that fits and stays put. Personally I have my custom toolbar that I move around the screen as needed and the rest of the large tool set tools on a smaller bar top left for when I need those (for me) less used tools.

1 Like

Might try that sometime, never made a custom toolbar before…
But it is working again for now.

Here’s an old link showing how if you want it.

1 Like

Thanks @Box, I never considered that it was the actual toolbar that was causing the issue. To be honest, throughout my entire CAD career, I had always been rather OCD about what I had on my screen, regardless if i used it or not. From AutoCAD to Microstation to SU, I seemed to have a flow in what I set up on my screen, hence the large toolset being displayed. I am pretty savvy with using keyboard shortcuts with SU, despite having the toolbar out there. I even considered yesterday to ditch it altogether but the OCD kicked in again, and I left it alone.

Anyways, thanks for the revelation. I too had noticed that even though the large toolset had a two-column layout, it was never wide enough to place two columns below of toolbars…that should have been the tipoff that something was not quite right. I’ll look into that custom toolbar tutorial and see if that suits my needs better.

1 Like

You could even replicate the large toolset as two single bars so you’ll never notice it has gone.

1 Like