Retaining Workspace issue in Sketchup 2018


#1

Hi All

I am having problems with both Toolbar positions and trays in the windows version of SU 2018.

The toolbars will not stay in position and newly created trays are completely erased (not listed in tray manager) when reopening SU. Toolbars load OK but do not retain position.

The workspace on SU 2016, 2017 works fine and is retained on the same machine.

I am using a dual monitor setup but does not work either on single monitor;.

I have installed SU 2018 with User Admin option\rights and reinstalled and repaired installation.

I have exactly the same plugins installed as per SU 2017 albeit some are older plugins.

I have checked anti virus firewall etc.

A real pain particularly regarding custom trays being removed. Anyone any ideas ?

Best wishes and thanks in advance.

Steve Booth


#2

Bump.

Same here. Even tried the old ‘run installer as admin’ - no joy. Then tried always run sketchup as Admin. No joy.


#3

Many Thanks for your response

I finally managed to rectify problem by uninstalling again and manually deleting all content before installing with administration rights.

The Vray 3.6 tool bars are still not playing nice though. I cannot get them to dock in a permeant position.

Thanks again

Boothy


#4

I’ve just upgraded to 2018 and am also having problems. The tray setup will not save and I am having to remake it every time I open a model.

I’ve installed as administrator, repaired, deleted and reinstalled, redownloaded the exe file etc etyc repeatedly but the tray setup just will not hold.

Any solutions appreciated.


#5

Add me to this list but I am only having problems with the V-Ray tool bars. This is SketchUp Pro 2018. Any help would be appreciated greatly.


#6

Any updates on this? I’m trying to find a solution as it begins to become annoying to me.


#7

I have the same issue. I try to run as administer. BUT ITS DIDNT WORK


#8

I recently began experiencing this also and it is very frustrating to reposition most of my toolbars every time an instance of SketchUp is opened. It just started last week and had never occurred before.

Reading through the Knowledge Base, I came across THIS ARTICLE and I tried several of the things identified in it including resetting the Workspace but no joy so far. I’m going to try removing the program and reinstalling as an admin once again to see if the issue goes away, but that is a job for tomorrow. I’ll post an update and I hope some enlightened user can find a solution soon.


#9

I am having the same problem. Back to 2017 for me.


#10

Is this problem just the top toolbar?
I moved mine around a little while ago and they were jumping all over. I now keep the standard toolbars to the left and extensions to the right of them and they hold in place.
I’m no-one to diagnose this but it seemed that they only moved when I had an extension on the “left” of a standard native toolbar. That’s how it went for me.


#11

I removed and reinstalled as admin. No plugins. Trays still won’t save. Could imported shortcuts be an issue?


#12

Ok, I got my trays working. I had to uninstall and delete any hidden files for 2018. Reinstalled as admin and trays are working.


#13

As an update: Uninstalling and reinstalling as administrator etc didnt solve this problem for me. It was connected with the fact I was using a multi monitor setup, which was pointed out by sketchup support.

So if anyone is still having problems and using extension monitors unplug those then do the uninstall/reinstall on the base machine. In my case everything was fine after that.


#14

IT’S A SHAME!!!
I have spent almost two hours on setting my toolbars trays on two displays.

What a piece of ■■■■! The very basic customisation is completely bollocksed!
I have repaired the installation as admin, added exception of my antivirus program. In vain.
All sucks.


#15

Same for me, just upgraded to 2018 and vray 3.6. Never had this issue on any other sketchup version except for this one. I’ve tried everything mentioned on here even the multi-monitor thing and to no avail. None of my toolbars stay in place. It’s very annoying as I use sketchup professionally for exhibit design so I need to have sometimes 3 instances open at once daily. So I’ve given up and just leave them floating out of the viewport on my second monitor until they either provide a fix or an update. Sucks to pay so much for software that has an annoying bug such as this.


#16

When you installed SketchUp, did you right click on the installer exe file and select Run as administrator or did you double click on it?


#17

Right clicked and installed as admin. Doing this only fixed an issue I had with plugins not updating, that was annoying too. But I’ve tried everything mentioned and my toolbars still do not stay in place.


#18

Thread closed??? So, what is the solution?
I used to be able to have 5 separate trays open on the side monitor. This is invaluable as you have a perfect overview of everything. Now the trays are truncated and only individually available via tabs at the bottom; how stupid!!!


#19

Yea not sure what’s going on with this, I am still having to re-arrange my toolbars every time I open sketchup. I use it for work everyday and it’s a very annoying bug. I have tried everything and nothing has fixed this. Now I’m experiencing freezes every 15-20 mins on even the lightest models. I’m using a rig build specifically for Cad with a quadro 1000 card 32gigs of ram and a beefed up i7, Never had these problems with sketchup pro until 2018. Thinking about changing back to 3ds max or maya for the work I’m doing.


#20

I had the same issue,
What worked for me was to find the file
PrivatePreferences.json
which was located at: AppData\Local\SketchUp\SketchUp 2018\SketchUp
and copy this file to the same location as the
SharedPreferences.json
which was located at: AppData\Roaming\SketchUp\SketchUp 2018\SketchUp
and for some reason that worked!!

Hope that helps…