Retaining Workspace issue in Sketchup 2018

I still have this problem too.
Will there be any maintenance issue which deals wit this problem?
I have been putting off 2018 version for quite some time now.

If you’re experiencing this problem, could you open a command prompt window and type the following commands?

OS get Caption,OSArchitecture,Version<enter>

Copy/paste the output of those commands, or send them directly to me via private message.

If anyone is having problems saving their SketchUp workspace, please contact me directly. Thanks to the efforts of @josephkim626 we may have figured out the issue and have a possible workaround.

1 Like

I am having this problem for some of my users. What is the solution? Thanks in advance.

Here’s the workaround:

  1. Create a second Windows user on the system where SketchUp isn’t saving the workspace.
  2. Assign administrator rights to the user that you just created.
  3. Remove administrator rights from the original Windows user (i.e. the one who can’t save their SketchUp workspace).
  4. Reboot the system.
  5. Log in as the original Windows user.
  6. Launch SketchUp, make a change to the workspace, and quit SketchUp.
  7. Re-launch SketchUp; you should see the changes reflected in the workspace.

What if you don’t have admin rights assign to the user that is having issues? This is in a corporate environment.


The main user (account) won’t have admin rights.

This worked. Thanks!


When you copied the PrivatePreferences file from Local to Roaming, did you also delete it from the original location?

Mark Chandler

Not sure if there was an update to windows recently but upon opening up sketchup this morning all of my toolbars are docked in place, albeit I tried to re-position them but after saving and reopening their re-positioning was undone but still docked. Which I can live with for now. I tried all the workarounds and “fixes” reinstalled over 6 times but nothing had worked. So I’m not sure if it was a recent windows update or something else. All I know is that Sketchup was no bueno on friday, I opened it this morning and it’s fixed.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.