Loading, opening new file very slow since upgrading to 2017


#1

Since upgrading to 2017 (fresh install) it takes much longer to run File > New or open an existing SKP file. Even small files can take 20-30 seconds or more. Larger files hang for closer to a minute. 2016 didn’t have this issue for me. I’ve still gor 2016 installed and it does not have the same problem on the same machine. 16 opens files instantly.


#2

When you installed SU2017, did you install it properly by right clicking on the installer and choosing Run as administrator?


#3

I don’t think I installed as administrator. Can you explain why that would have this effect?


#4

Because SketchUp has to make some changes that require it be installed using Run as administrator. And being listed as Administrator isn’t sufficient, either.

Also see this: Important Update on a few Potential SketchUp 2017 issues on Windows

Make sure your graphics drivers are up to date, too.


#5

I’ve customized my watermark and a set of materials as well as my preferences. Can I reinstall over my current install and keep all of my customizations?

Thank you for your response, by the way.


#6

Yes. When you run the installer again using Run as administrator, it’ll give you the option to repair the installation. It won’t overwrite anything in the User/AppData/…/SketchUp directories.


#7

Thanks. I think my graphics driver is not up to date either so trying that first.


#8

Definitely repair the installation because it isn’t correct if you didn’t use Run as Administrator.


#9

Will do. Just want to update the graphics drivers first. I have intel graphics and this seems to be a known issue with those based on your link.


#10

Repair install as administrator didn’t fix the problem.


#11

It will have fixed other problems you haven’t run into yet.

What about the graphics drivers?


#12

Updating graphics drivers appears to have not had an effect.


#13

This topic was automatically closed after 91 days. New replies are no longer allowed.