Is my GPU working?

Before I replace/upgrade my GPU in need to check if my current one is useless or there is something else wrong.

Model has rough;y 6500 edges and 3200 faces. With nothing hidden, it takes 10 minutes to open the file, mostly with “Not responding” showing. Task Manager shows just the occasional flicker of about 1% for GPU usage.

This seems wrong to me.

How long does it take to open SketchUp to a new file/session? Maybe you have some extensions that are causing the delay in opening.

When you installed SketchUp, did you do it correctly? That is, did you right click on the downloaded installer and choose Run as administrator? Or did you just double click on the installer?

Are there a bunch of textures with large file sizes?

Maybe you could share the SKP file so we can compare to see how long it takes for us.

I highly doubt there’s anything wrong with your GPU, especially since it isn’t really tasked with anything while opening a file. Its job is really all about displaying 3D geometry on screen, which shouldn’t be a heavy load based on your description.

2 Likes

DaveR: Will start with reinstalling as administrator.
Will check the textures.
Will do the file upload tomorrow (very late now.)

Make sure you are signed into Windows as your normal user. Make sure SketchUp is closed, too. After you right click on the installer and choose Run as administrator, select the Repair option.

monospaced: I understand, nothing is displayed until the model is loaded,so GPU not involved until then.

Will do the repair thing.

Have you checked the “Show nested components” box in the Statistics dialog? Otherwise the count ignores all edges and faces that are inside components

Anssi: Makes a big difference.
But the good news is that Repairing as administrator did the job. Should have read the installation instructions better. :roll_eyes:

Thanks for the help, everyone.

2 Likes