Sketchup 2019 little bit slower in opening

I notice skp 2019 is slower than all versions in opening.
Why we use latest version.

Did you install by right clicking on the downloaded installer file and choose: “Run as Administrator”?
Do you have the ‘latest and greatest’ driver for your video card? (And is it also installed by rightclicking etc.?)

If on a laptop, do you have set the energy/display settings to ‘use the dedicated or strong videocard’?
(rightclick on the desktop to see the graphic settings)