Lines missing in hidden line style


#1

I have to produce black and white views of the models i draw. I used the hidden line style with the profiles turn on and set at 1 in the edge settings. This gives a clean look, but i get lines missing on parts of my model.

i have tried to look up solutions - i dont really understand what anti aliasing, or open gl settings mean or do.
where can i get a basic walkthrough of things i should check or change?


#2

Turn on ‘Hidden Geometry’ and open the ‘Entity Info’ window.
Examine the (now showing) hidden edges to see if they are indeed hidden. I suspect that you set some edges to ‘Hide’.

Otherwise please share the model to look at.


#3

Also ensure your Style has profiles ON - even if they are set to have the same thickness as ordinary edges…


#4

i cant work out how to upload it, it says its too big, also in a zip! :confused: how do i share the file?

yes it certainly does seem to happen on objects that have softened lines in them, or the sides of pipes which are long cylindars that i create with a plugin call 3skeng.

what do i do about it?


#5

What is the file size?
Try uploading to 3D Warehouse and then share the link to it here on the forum.
Or upload to some file sharing program (say DropBox) if the size still matters.

With profiles on and set to 1 or higher you should be able to see the outline of the valves /elbows etc., provided that the edges are not hidden. (soft and/or smooth does not matter)
Try profile set to 2 to see what happens. Be sure they are on.


#6

The size of the file is 4,924 kb - is that too big? i have uploaded to warehouse, but will only turn it to public when i know you are there. i do not want to leave the model in the public domain for more than necessary


#7

I have profiles set to 1 and still have lines dissapearing If set to 2 they become too thick.


#8

You haven’t answered if these specific lines are hidden. That is essential.

(The ‘Profiles > 2’ was just for troubleshooting, to see if contours would still be missing with (some) lines hidden)


#9

do you have sketchup open? i can share the model with you


#10

Yes, it’s running.


#11

ok search in warehouse

Field Valve Figure

scroll through the scenes to the b/w views which is where the missing lines are


#12

the problematic lines are softened lines, not hidden ones.


#13

Yes, I can see that now that I’ve opened the model.
I think it has to do with softened/smooth lines (although I found some hidden lines too) close to each other and how OpenGL deals with them when displaying the model when one is just close behind another.
I think it’s an interesting looking model, but at several points way too over_complex as to creating geometry. And there are rounding issues at ends of T_pipes (end maybe also at ends of elbows) The segment counts don’t match, leading to too many edges close to (= behind) each other.
Also at at least one point intersection wasn’t right, see:


The elbow seems to (and is) continue inside the valve top. (scene 5)
There are bolt shafts missing in some places (has nothing to do with your display issues though).
I’ll have a closer look later to see if simplifying the rounding ends and dealing with the many diagonal lines in T_pipes etc. does displaying any good. Need more time. My “regular” work needs to be dealt with too :upside_down:


#14

Hi Wo3Dan - thanks so much for looking, here are some screen shots of the scene views showing where i see lines missing.

soooo frustrating!


#15

Here another example where there is no proper intersection, so no edges (in red area) to display):


#16

This is a straight hidden line export from your model. I exported at 2000 pixels wide.

And this is a screen shot:

I expect Wo3Dan is on the right track with the way your graphics card handles OpenGL. And the hidden or non existent edges.

It is an interesting looking model.


#17

When I changed the OpenGL settings (see Preferences) for Multisample anti-aliasing from 0 to at least to 2x and to 4x I got different (=better) displaying results.


#18

ah ok, i tried that, my laptops graphic card wont enable a setting above 0 :frowning:


#19

oh wow - it look soooo much better than when i export!!


#20

Which graphics card is being used by SketchUp?