Missing edges

hi guys, i’ve downloaded a model, which i wish to view as an outline, however this one has no edges. I always view the model as styles / straight lines (not sketchy lines). Usually the straight lines always work fine. this one is the first time I can’t see a thing. It does show the form when I choose hidden geometry (shows dotted). but I dont want that. I wish to have it lineart. Btw I’ve also tried setting up the smooth/edges slider since sometimes it helps bring out some edges, but it doesnt work either, and i’ve tried the whole range. I’ve also checked that edges is selected under the straight line style (which it is by default)

I’m not very famliar with some of the apps features like components, layers and such so i’m not sure if one can hide the edges from there too.

model can be found here

thanks in advance

My guess would be that the edges are softened (and probably also smoothed). This causes the edges to be invisible unless Hidden is enabled. What happens if you enable Profile edges in the current Style? This should cause SketchUp to display the projected outline of the object (as seen from the camera point of view), regardless of whether the edges forming the object are softened.

If you want the edges forming the object to be visible, I would turn on Wireframe on the View menu, turn on Hidden, then select all, the use the Entity Info window to tick OFF the soften (and smooth) toggles. Do this while in the editing context of the object (aka, group or component).

1 Like

The model has all its edges smoothed. Using a style with Profiles turned on might be the best solution.

1 Like

It’s a common thing for people to hide unsoftened edges when they upload to the Warehouse. You can unsoften and unhide the edges. Also it might help to turn on Profile edges in the style if they aren’t on.

1 Like

thanks thats the solution! i was doing just unsoften, but needs to be unhide aswell.
pretty neat trick this one to hide edges, didnt know about.

also thanks @Anssi and @TDahl for helping out. Profiles were turn on, however my entity window does not have the off option for soften. I’m using ver 2017 and I only have

You can select all of the geometry (triple click on it with Select) and then go to the Edit menu and choose Unhide>Selected.

hmm just tried it and still not showing up.
i’m getting this

but i guess its ok since i’m using the soften/edges panel. The only annoyance of it is that i need to do the model bit by bit (like the hair on its own, face, etc)
exploding the model helps but it will still have some sort of grouping.
is it possible to fiddle with the slider as a whole cause i’m kind of lost in the selections with all these triple clicks :frowning:

I haven’t had time to download that component but if it is divided into sub-groups or components, you’ll need to edit them individually and unhide/unsoften the geometry inside. Or you can explode them all so all the geometry is in the same context. Of course that might have other implications. It might make it easier on your computer’s processing if you select the Monochrome face style so textures don’t need to be rendered. Or maybe it makes more sense to do the modeling yourself. Kind of depends on the need I guess.

Personally I find it annoying that so many components/models are uploaded to the Warehouse with all edges hidden or softened. It makes them more difficult to work with.

1 Like

A large part of the difficulty working with that model is that it has a very deep and pointless nested group structure, with many groups containing nothing but the next deeper group in the nest. You could explode most of them with no loss. As is, you have to drill all the way down to the group that actually contains edges and faces to change their properties. SketchUp’s Unhide and Unhide All work only within the currently open edit context.

If you just want to view the mesh, you could choose a monochrome style and activate View->Hidden Geometry.


@DaveR @slbaumgartner true indeed, especially for a beginner like me. for now i’m still figuring out the structure of the application like layers, groups, component and what not. coming from an adobe background i’m still finding it hard to grasp how layers and group work in sketchup. not much in common with adobe, sort of.