Layout viewports are not syncing to model

I inserted the model to layout. When I make changes to the model, I save model and
then go to layout and update model reference. Somehow the viewports are no longer
allowing the updates. I tried relinking the viewport to the model. no luck. Maybe I am
doing it incorrectly? I have started sending the model to a new layout template and it works


In layout is rendering set to auto, it’s a tick mark lower left of the SketchUp model pallet? Select a viewport then check that pallet, If you have manually paused auto rendering you may see a yellow exclamation mark indicating that there is re-rendering to be done. There is a render button, or put it back to auto. Excuse the typos, I’m on my phone.

It would help if we could see your LayOut file. As EF suggested, maybe you haven’t got rendering set to auto. Have you made any changes in LO to the scenes?

I see the yellow exclamation mark on the layout viewport. The render button is on.
In LO I had viewports locked and that brought up the yellow exclamation, so I have unlocked them.
I did not change anything in the model from layout except cropping the viewports.

Did unlocking them allow them to update?

How did you do the cropping?

Again, seeing your LO file would be a big help. It would also eliminate the time spent guessing at the problem and solution.

Unlocking did not allow to update.
Cropping I highlighted and pulled the viewport
I will send the layout file.

If the file is too large to upload here, upload it to Drop Box and share the link. If it contains client or other sensitive information, you can feel free to send it via a private message. I won’t share that information.

I tried uploading and dragging the file in but there was an error message.
What should I do?

What was the error message? Likely the file is too large. If it is, do what I wrote in my previous post and upload it to Drop Box and share the link.

Over 1 Gb. Definitely too large to upload to the forum. It’s slowly downloading now. I’ll take a look when it has finished. As I suggested yesterday, if this file has any sensitive information that you don’t want to be out in the wild, you could have sent it via private message. At this point if there’s info you don’t want the whole world to access, you could edit your previous post and eliminate the link.

not sure how to eliminate link and what is the private address to send

Click the pencil icon under that post and edit it to remove the link. To send a private message (which you don’t really need to do now) click on my name and then the Message button.

OK. I’ve only looked at the Basement Plan page so far. As you wrote last night, the viewport was locked. When I unlocked it, the rendering started immediately and updated. After updating it looked like this:

I opened the SketchUp model file and added a hexagon, saved the file and went back to LO. The viewport updated to show my change as expected.

Removing the hexagon and saving the change to the SketchUp model also rendered immediately.

I did do a bit of cleanup in your SketchUp model. There were a few edges and faces that were incorrectly tagged.
Screenshot - 4_23_2021 , 7_48_59 AM

And a lot of unused stuff to purge.
Screenshot - 4_23_2021 , 7_49_26 AM
That reduced the LayOut file size by a little more than 83%. It also helped to speed things up in both SketchUp and LayOut. I didn’t go through the styles but from looking at your LO file, I’d bet my lunch money that you don’t need all 14 of the remaining styles for this model. Eliminating the unneeded ones wouldn’t change the file size much but it would make the model easier to deal with.

Added: As I go through the document I’m finding the viewports are locked. When I unlock them they are able to render. I think you might find it helpful not to lock the viewports. I’m also finding that your viewports seem to be on the wrong layer in LayOut. Better practice would be to keep them on a layer or layers separate from the rest of the document content included the shapes you are drawing for poche. If you feel the need to lock something, lock the layer(s) instead of the viewports. The viewports can still render when you update the SketchUp file.

So the file was big and did not allow updates fast enough , because when I unlocked the
viewports it still did not allow updates.
I will try here now…

So what you did is changed my LO file on this end?

I still need to eliminate the 14 styles for this model?

Is there a tutorial to help understand steps better?

I expect that’s it. You needed to give your computer time to do what you were asking it to do.

I opened the SketchUp file that is embedded in the LayOut file and purged unused. You can do that through Window>Model Info>Statistics. I use a plugin to do it only because it generates the report window when it completes so I can show how much was removed.

You can’t get rid of all of them. There has to be at least one style and it may be that you actually need more than one but from looking at the vieports in your LO file, I’m guessing you have at least a few styles that are duplicates.

There is the Essentials tutorial series at although I don’t think it really goes into the stuff I did to fix the things I did. It will hopefully help you to understand LayOut better. The key thing, though, is to keep your SketchUp models lean and efficient so you don’t have a bunch of unneeded details that your computer needs to process.

The layout is still not updating to model. But when I insert the model to
another layout template it does update.

When you open the original layout file, what does the Document setup>References page say? Has the model become detached from the original model you are editing? @DaveR edited the model that was embedded to your LayOut file, and for him that updated fine. Just thoughts.


Also, I’m assuming you dropped a single viewport into this new Layout file. That will render like lightning compared to whatever you have in the other file. I’m working with a ~10MB model, and I only have six pages (a few with 12 viewports each), and it takes a good 45 sec to a minute to update that. At a gig of information, I can’t imagine what you’re going to be waiting for. Even after you’ve slimmed the model down, Layout will take a while to update to that state.

@Ansii has a good point. Are you editing the model that is actually linked to the LO doc?

In your LO file, right click on the unlocked viewport and choose Open with SketchUp. That’ll open the file that the viewport is linked to.

Thanks, I will try all suggestions…