Layout too slow to use

Been using SketchUp and LayOut for the last 3 or 4 years or so. Sketchup runs great for the most part, but its getting to the point where LayOut is unusable due to its slow speed and response time. For instance, simply rotating an object has a lag of about 2-3 seconds.

I built a computer specifically to run Lumion, so I know my hardware is fine:

Intel i78700
GTX 1060 6GB
16 GB RAM

After reading some of the posts on this forum, I am just at a loss. I use scenes for everything, groups and components, etc. I am not a beginner when it comes to either program.

The file size of the model in question is only 24 mb.

Any thoughts? Are there any settings I can change to make LayOut run like it should? I cannot be the only one experiencing this.

Thanks in advance

Are able to share the files?

Can you do a test where at the time that it is lagging you zoom into the page by a tiny amount? Does zooming make any recent changes catch up?

The zooming in with my scroll wheel takes forever. That’s one of the main issues.

Unfortunately not. The file doesn’t seem to matter, LayOut seems to be “bogged down” if there is a large .SKP file attached to it.

I broke down the part of the file I needed into a smaller .SKP file and that seemed to do the trick. It’s still very disappointing that LayOut can’t seem to run correctly with a large file “referenced”.

Have you recently upgraded SU version?

No, currently running SU and LayOut 2018

I guess we’ve not much to go on.

You’re probably aware of the various options available in LO to improve performance and SU modeling techniques to make the workflow from SU to LO as optimum as possible.

Also updating drivers, etc.

I’m not much into the specifics of hardware so can’t comment on your specs.

There have been improvements in speed in both LO2019 and 2020. Might be worth considering updating.

Without something to look at it’s like Paul wrote, there’s not much to go on to help you.

How many faces and edges (with the nested components option enabled)? If a 24 MB file has many instances of heavy components like 3D plants or cars, the count would typically run into many millions. Faces and edges are what affect SketchUp or LayOut performance and the file size is of secondary importance.

I think I am aware of those options you speak of, but I suppose I could be missing something.

Is there anything you can think of?

That’s a good point.

I have 140k edges in this particular model, and 71k faces.

Would that be considered a lot?

That ought to be quite manageable. Did you really have the “Show nested components” box ticked?

I didn’t meant that you would zoom in and out, just do a momentary zoom in of any amount. Does the page refresh?

Many of my SU files are below 10MB, even below 5MB.

I’ve trawled through some past projects looking for large SU files.

Going through them after purging them of components the file size is much reduced.

Many of my models get larger than 10MB if I import furniture and fixture items from the Warehouse.

I once created a model where I imported a roof tile from the Warehouse and had, perhaps, a couple of hundred instances of it in the model. The LO file was incredibly slow and it took me a while to realise why!

In LO>Document Setup>Paper there is the option to set the Display Resolution. Also there’s the auto render setting for viewports that you could untick.

When you say

do you mean rotating LO linework?

I mean rotating the viewport for the SketchUp model. Takes ages

Rotating the viewport or orbiting the camera in the viewport?

Rotating the viewport. I don’t go into the model from layout at all

That’s good.

Update: I “upgraded” to Sketchup 2020 and still no change. This time I am importing .jpg files (someone else’s drawings) into layout to red-line and make changes. Still extremely slow.